Ajuda com Node-RED no HASSIO


(Rui Barroso) #1

boas pessoal,
instalei o Node-red no HASSIO como o tuturial, ja me aparece na lateral esquerda o Node-RED com o icon, quando clico abre nova pagina em https://hassio.local:1880 mas o chrome diz “nao é possivel aceder a este site”

esta é minha config do Node-RED

{
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "users": [
    {
      "username": "meu user name",
      "password": "minha pass",
      "permissions": "*"
    }
  ],
  "http_node_user": [
    {
      "username": "meu user name",
      "password": "minha pass"
    }
  ],
  "projects": false,
  "install_packages": [],
  "install_nodes": [
    "node-red-contrib-home-assistant"
  ],
  "uninstall_nodes": []
}

(Rui Barroso) #2

[img]

resposta : hassio.local recusou estabelecer ligação.

Log
[INFO] Enabling SSL
[INFO] Updating IDE Users
[INFO] Adding IDE User jruibarroso
[INFO] Updating HTTP Node User
[INFO] Adding HTTP Node User jruibarroso
[INFO] Disabling Projects
[INFO] Attempting to install/update nodes: node-red-contrib-home-assistant
npm info it worked if it ends with ok
npm info using npm@5.0.3
npm info using node@v8.1.3
npm http fetch GET 200 https://registry.npmjs.org/node-red-contrib-home-assistant 417ms
npm http fetch GET 200 https://registry.npmjs.org/node-red-contrib-home-assistant/-/node-red-contrib-home-assistant-0.3.2.tgz 314ms
npm info lifecycle node-red-contrib-home-assistant@0.3.2~preuninstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~uninstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~postuninstall: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~preinstall: node-red-contrib-home-assistant@0.3.2
npm info linkStuff node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~install: node-red-contrib-home-assistant@0.3.2
npm info lifecycle node-red-contrib-home-assistant@0.3.2~postinstall: node-red-contrib-home-assistant@0.3.2
npm WARN saveError ENOENT: no such file or directory, open ‘/share/node-red/package.json’
npm info lifecycle undefined~preshrinkwrap: undefined
npm info lifecycle undefined~shrinkwrap: undefined
npm info lifecycle undefined~postshrinkwrap: undefined
npm WARN enoent ENOENT: no such file or directory, open ‘/share/node-red/package.json’
npm WARN node-red No description
npm WARN node-red No repository field.
npm WARN node-red No README data
npm WARN node-red No license field.

npm info ok
npm info it worked if it ends with ok
npm info using npm@5.0.3
npm info using node@v8.1.3
npm info lifecycle node-red-docker@1.0.0~prestart: node-red-docker@1.0.0
npm info lifecycle node-red-docker@1.0.0~start: node-red-docker@1.0.0

node-red-docker@1.0.0 start /usr/src/node-red
node $NODE_OPTIONS node_modules/node-red/red.js -v $FLOWS “–userDir” “/share/node-red”

Error loading settings file: /share/node-red/settings.js
{ Error: ENOENT: no such file or directory, open ‘/ssl/privkey.pem’
at Object.fs.openSync (fs.js:651:18)
at Object.fs.readFileSync (fs.js:553:33)
at Object. (/share/node-red/settings.js:137:17)
at Module._compile (module.js:569:30)
at Object.Module._extensions…js (module.js:580:10)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
at Module.require (module.js:513:17)
at require (internal/module.js:11:18)
errno: -2,
code: ‘ENOENT’,
syscall: ‘open’,
path: ‘/ssl/privkey.pem’ }
npm info lifecycle node-red-docker@1.0.0~poststart: node-red-docker@1.0.0
npm info ok


(Jorge Assunção) #3

@jruibarroso quando publicares código deves sublinhar o texto que queres transformar em código e clicar no icone </>. Deverá existir um espaço antes e outro depois do bloco de código para que funcione correctamente. O código em Yaml é muito sensível aos espaçamentos e sem o código devidamente formatado não te poderemos ajudar.


(Rui Barroso) #4

só tinha 5 linhas de codigo yaml , ja removi
o que tenho é só o LOG


(Jorge Assunção) #5

Tens a config do Node-Red na primeira publicação.


(Rui Barroso) #6

já corrigi , sou novo nestas andanças e nao sabia , peço desculpa


(Jorge Assunção) #7

O problema está nos URLs que usas. Não deves usar o hassio.local mas sim o endereço IP da máquina onde está o NR está instalado seguido de 1880 (http://192.168.xxx.xxx:1880).