ArMhasSio como instalar o Home Assistant (hassio) em boxs Android - dúvidas


(Ricardo Azevedo) #42

Belo tutorial Parabéns! Veio mesmo a calhar…
Está aí a chegar uma Tanix Tx5 Max com S905X2 com esta configuração: https://pt.gearbest.com/tv-box/pp_009591888713.html
Como não sabia bem o que fazer com ela, pois por norma prefiro o Android TV, mas neste caso vou mesmo colocar o HA… e sugerir à malta que segue a AMCD a fazer o mesmo, dando créditos a este Tutorial!
A versão é 4GB/32GB já alguém passou pelo processo? Alguma recomendação especial?
Nota: Ainda não recebi a box


(Rodolfo) #43

hum, @rmcazevedo esse processador é diferente não sei se é suportado.
@Maddoctor sabes se tem suporte?


(Ricardo Azevedo) #44

@RodolfoVieira acredito que seja uma segunda versão do S905X… mas como já está a caminho era alguma utilidade que posso dar a box, pois todas as anteriores que tive dei…
Tenho outra a caminho, mas acabei de validar também tem o mesmo S905X2, mas terá um destino diferente, pois possui armazenamento para um disco extra, e assim vou tentar criar outras ideias!
Obrigado pelo feedback! Keep the good work!


(Sebastião Lopes) #45

Ponto de situação:
Fui insistindo com dtb diferentes e versões de armbian diferentes. Sempre que tinha cartão não aparecia nenhum IP. Como tinha a box ligada a uma TV e perto não tinha possibilidade de ligá-la por cabo ao router, desconectei-a da TV e trouxe-a para perto do router, ligando-a por cabo. Passou a aparecer IP e a partir daí o processo de instalação decorreu normalmente. Parece não ter surgido nenhuma anomalia na instalação só que colocando no browser o http://IP_DA_MINHA_BOX:8123 não aparece nada. Pelo putty tenho acesso sem problema. Será que é como no raspberry e demora algum tempo para arrancar?
Cumprimentos
Sebastião


(Tiago Marques) #46

Algum tempo vai demorar sim. O processo é o mesmo.
Vai tentando abrir, no PI demora uns 20m, na box talvez demore menos.


(Sebastião Lopes) #47

Boa noite
Decididamente em http://IP_DA_MINHA_BOX:8123 não funciona. Não sei o que terá corrido mal. Será que nesta altura ainda posso tentar outro dtb?


(Nuno Neves) #48

É suposto ligares por cabo… Perdes o Wi-Fi com esta conversão na maioria das vezes ou, pelo menos, tens de tentar instalar os “drivers”…
Ou seja, ultima versão com p281 funciona, certo? É o que é suposto…
Já correste o script para instalar para o emmc e reiniciaste a box sem cartão antes de correr o script para instalar o hassio?


(Nuno Neves) #49

Podes sempre tentar dtb porque a box, tendo cartão com SO, arranca sempre a partir dele… De qq forma não deve ser esse o problema…


(Nuno Neves) #50

Lamento, mas se a tua intenção era seguir este tutorial, apostaste no cavalo errado… Esse processador, para já, não tem suporte nenhum para nenhum tipo de instalação Linux… O s905x2 é MUITO diferente do s905x… Lamento…


(Sebastião Lopes) #51

Bom dia
A instalação que decorreu sem problemas foi com a versão 5.68 e com gxl-s905w-p281.
Vou ver agora com a última versão e com o mesmo dtb.
Uma pergunta: é suposto quando estou a chamar o ip da box já ter o hassio do raspberry desligado para não haver conflitos?
Obrigado


(Tiago Marques) #52

Se tiverem o mesmo ip, SIM.


(Sebastião Lopes) #53

Não estão com o mesmo ip mas têm o mesmo nome hassio que surge com o ip. Se desligo um, hassio2 passa a hassio. Além disso, embora me pareça que por enquanto não é problema porque ainda não chamo o hassio da box de fora da rede, a porta 8123 no router está aberta especificamente para o ip do raspberry. Penso que ainda posso manter isso. Certo?


(Nuno Neves) #54

quando reformares o pi, os encaminhamentos deverão ir todos para a box… Isso inclui mosquitto e afins


(Sebastião Lopes) #55

Depois de muito insistir com diferentes versões de Armbian e diferentes ficheiros dtb, estava quase quase quase a deitar a toalha ao chão quando sem saber como nem porquê aceitou o ip. Foi com a versão Armbian_5.71_Aml-s905_Debian_stretch_default_4.20.2_20190122.img e o meson-gxl-s905w-p281.dtb
Agora penso eu que posso instalar o samba e copiar o último snapshot. Certo?

Obrigado a todos

Cumprimentos
Sebastião


(Nuno Neves) #56

Já instalaste para o emmc?
Quanto ao restauro do snapshot, apenas podes restaurar as config do snapshot do pi porque a arquitectura agora é de 64bit… Ou seja, não podes restaurar programas, add-ons incluídos…


(Sebastião Lopes) #57

Olá Nuno
Já instalei para o emmc e já instalei o Samba. Não entendi muito bem o que posso ou não copiar. Por isso, nas calmas, vou refazer tudo instalando addons e fazendo copy/past dos ficheiros yaml. Um addon que não tenho a certeza se preciso é o ssh pois, já tenho acesso à box pelo putty.


(Nuno Neves) #58

Idealmente deves instalar o addon ssh da comunidade, não o oficial, com uma porta que não seja a 22,para teres acesso ao “interior” do hassio e não ao SO…
Que tal a experiência com ArmHassio, para já?


(Sebastião Lopes) #59

A experiência está a ser óptima. Tudo é muito mais rápido


(Nuno Neves) #60

Top! Ficamos contentes que gostem… :wink:
Para quem começou nisto pelo octoprint… Já ganhaste o vício pelo resto! Hehe


(Rodolfo) #61

@sslopes boa, ainda bem que tudo funciona como expectável. Vamos adicionar a tua box e stb à lista.