ArMhasSio como instalar o Home Assistant (hassio) em boxs Android - dúvidas


(Rui Barroso) #82

Sim. Nem aparece logotipo , já carreguei mnt tempo no switch mas nada…


(Rodolfo) #83

Possivelmente mataste a box, andas mais para cima e podes comprar uma igual ao que o sslopes comprou.


(Rodolfo) dividir este tópico #84

5 mensagens foram unidas em um tópico existente: Melhor hardware para instalar Home Assistant


(Nuno Neves) #89

Essa box é, provavelmente, salvavel! Não deve ser preciso comprar outra…
Tenta. Senão, eu gostava de tentar, nem que seja preciso desmontá-la para fazer experiências… :wink:


(Luis Belo ) #90

No meu só deu assim:

 #Wired adapter #1
allow-hotplug eth0
#no-auto-down eth0
iface eth0 inet static
address 192.168.1.65
netmask 255.255.255.0
gateway 192.168.1.254
dns-nameservers 8.8.8.8 8.8.4.4

(Hugo) #91

Boas, chegou a minha box Mecool M8S PRO W com Amlogic S905W, 2gb de ram e 16gb de rom.
Passei “Armbian_5.73_Aml-s905_Debian_stretch_default_4.20.2_20190130.img.xz” para um cartão microsd com o etcher.
Coloquei “dtb_name=/dtb/meson-gxl-s905w-p281.dtb” ni ficheiro uenv.ini.
Iniciei o update com a aplicação “update” mas a box reiinicia logo e fica “presa” no logo “mecool”. Alguma solução?


(Nuno Neves) #92

Muda para outros dtb com gxl no nome…


(Rodolfo) #93

@fonteshugo faz o que o @Maddoctor te disse, para isso terás que colocar novamente o cartão… no pc… e ire testando todos os dtb´’s que te aparecem na pasta… metes um voltas a por no cartão na box… não da? metes novamente no pc e depois na box… e por ai fora até dar.


:warning: SÓ tentas os que começam por gxl


(Hugo) #94

@RodolfoVieira testei todos e não iniciou com nenhum. a box mantem-se em modo de inciar pelo cartão certo? Que mais posso fazer?

edit: segui o tutorial https://community.openhab.org/t/openhab-on-an-android-tv-box-running-armbian-setting-it-up/39501 e com a versão Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img.xz está a iniciar. Com as versões mais atuais não deveria também funcionar?


(Nuno Neves) #95

tenta com a penúltima do debian…
de qq forma pode ser um download corrompido, o que fizeste…


(Rodolfo) #96

Mas exprimentaste esta versao Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img.xz com o dtb que tavas a usar??


(Miguel Costa) #97

bem estou a instalar numa w95 e cheguei a uma paret que me pede login

Diz : Debian GNU/Libux 9 aml tty1
aml login:

e nao sai daqui

imagem Armbian_5.73_Aml-s905_Debian_stretch_default_4.20.2_20190130.img.xz


(Nuno Neves) #98

é agora que entras por putty… root - 1234


(Miguel Costa) #99

nao consigo entrar pelo putty mas liguei um teclado e fiz o mesmo processo na box ja fiz isto /root/install.sh

e deu instalaçao completa

tirei o cartao e volto entrar com root e pass e aparece " root@aml:~#" tento meter o link do github e nao da

EDITADO: tinha erros no link , ja esta a fazer download

EDITADO 1 : ja descobri o porque nao deu pelo putty… fiz confusao com os ip’s.
Ja esta a instalar o hassio
logo coloco aqui os passos que deu com esta box…


BOX w95 2GB RAM / 16 GB memoria
Custo 29€ na GB em promo vinda de espanha
imagem Armbian_5.73_Aml-s905_Debian_stretch_default_4.20.2_20190130.img.xz
dtb: meson-gxl-s905w-p281

hassio a funcionar


(Hugo) #100

@Maddoctor não percebi com o que testar. Não da erro ao passar pelo etcher e já testei com vários ficheiros.

@RodolfoVieira coma versão Armbian_5.73_Aml-s905_Ubuntu_bionic_default_4.20.2_20190130.img não funciona nenhum dtb, com a versão Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img funciona com o gxl_p212_2g.dtb.
Experimentei tambem a versão Armbian_5.71_Aml-s9xxx_Debian_stretch_default_4.20.2_20190118.img e não funciona.
As versões mais recentes não deveriam funcionar? Acho que o dbt deve ser meson-gxl-s905x-p212


(Nuno Neves) #101

Qual o tamanho do cartão? A dtb deveria ser a p281,mas qq uma que dê, serve…


(Hugo) #102

@Maddoctor O cartão é de 8gb. A versão que funciona também está num cartão de 8gb


(Nuno Neves) #103

Pelo que percebi, estão em cartões diferentes, o que significa que o problema pode ser do cartão… Experimenta trocar…


(Hugo) #104

Troquei o cartão e continua a não dar. o que tem de diferente o ficheiro de configuração entre a versão 5.37 e 5.73? o ficheiro dtb da versão 5.37 pesa 37kb e o da versão 5.73 pesa 25kb. Alguma coisa foi alterada para deixar de dar com esta box…
Quais os inconvenientes em instalar a versão 5.37? Não se consegue atualizar depois?


(Nuno Neves) #105

Em princípio tens de encarar o SO “as is”. Pode dar para actualizar pacotes, mas não é garantido… No entanto o hass.io que vais instalar é perfeitamente actualizável, ainda que o SO de base se mantenha igual… Instala uma versão mais antiga… mas tenta que seja debian e não ubuntu… não que seja péssimo, mas os tutoriais são quase todos para debian