ArMhasSio como instalar o Home Assistant (hassio) em boxs Android - dúvidas


(Anto Ferna) #106

Sabem se depois de instalar o armhassio, é possível reverter ??? ou seja é possivel colocar a box com o firmware de origem? obrigado


(Nuno Neves) #107

é possível se fizeres backup antes… usando o comando ddbr antes da fase de instalar para o emmc. Convém teres um cartão de 32gb para isso.
Depois de feito o backup, se um dia quiseres restaurar, arrancas com esse cartão, usas ddbr e escolhes restore…


(Anto Ferna) #108

não é possível de mais nenhuma forma?


(Nuno Neves) #109

deve ser possível usando o “amlogic card maker”, salvo erro


(Nuno Neves) #110

experimenta mudar o nome do dtb também no ficheiro “/extlinux/extlinux.conf”… tenta com o p281


(Anto Ferna) #111

apareceram-me vários erros durante a instalação : https://pastebin.com/9QnSqGEB


(Miguel Costa) #113

como faço para ir ao terminal para poder dar IP fixo? é através do putty ?


(Rodolfo) #114

@miguelmc é. Usas o armassio? qual a tua box?


(Miguel Costa) #115

sim armhassio, a box é a w95 , estava a tentar seguir o que um user acima fez numa box igual

dar ip estatico a porta ethernet:
no terminal:
Esta linha da… cd /etc/network/nano interfaces

MAs aqui ja nao da
alterar para:
source /etc/network/interfaces.d/*

EDITADO:
Ja consegui alterar o ficheiro…


(Nuno Neves) #116

Parece problema de permissões…


(Nuno) #117

Tenho uma box Mecool M8S Pro W, quero instalar o Armhassio, qual a imagem que aconselham e o dtb?


(Sebastião Lopes) #118

Boa noite
Há cerca de 10 dias (???) cá por Braga fez mau tempo, com relâmpagos e trovoada. Deitou-me a luz abaixo e quando tentava ligar o quadro eléctrico, não o conseguia. Dei conta que no neutro tinha corrente. Chamei um electricista para verificar o que se passava. Quando ele chegou, sem mais nem menos a corrente no neutro desapareceu. Só que, com este liga e desliga do quadro eléctrico, a minha X96 mini foi-se. Só conseguia instalar o ArMhasSio se tivesse o cartão inserido. Mal retirava o cartão ele não arrancava. Como não queria ter o hassio a funcionar desta forma, voltei ao raspberry. Entretanto mandei vir outra supostamente exactamente igual. Digo supostamente porque, se tenho no cartão a versão Armbian_5.71_Aml-s905_Debian_stretch_default_4.20.2_20190122.img e o meson-gxl-s905w-p281.dtb, a box sem o cartão não arrancava, mostrando, em vez de uma luz azul fixa, uma luz vermelha e azul intermitente. Fiz a instalação com a versão Armbian_5.71_Aml-s9xxx_Debian_stretch_default_4.20.2_20190118.img.xz e o meson-gxl-s905w-p281.dtb e está outra vez tudo a funcionar correctamente. Fui buscar a última cópia de segurança da box avariada e arrancou tudo sem problemas. Vamos ver se se aguenta.
Cumprimentos
Sebastião


(Nuno Neves) #119

Tenta a que o Sebastião descreveu no post seguinte…


(Luis Alves) #120

Boa Tarde Pessoal

Tenho uma wetek play 2 parada em casa e queria instalar lá o home assistant.

Segui as indicações correctamente e quando tento instalar aparece o seguinte erro :slight_smile:

– Install /sdcard/aml_autoscript.zip …
Finding update package…
Opening update package…
E:failed to mount /dev/block/mmcblk0 on /sdcard by read-only (device or resource busy)
Verifying update package…
E: footer is wrong
E: signature verification failed
Installation aborted.

Pelo que li, antes de instalar deveria correr uma recovery alterada mas nenhuma funciona porque a wetek tem a box bloqueada

Alguem já conseguiu resolver o problema ?


(Nuno Neves) #121

Em princípio não deveria ser necessário instalar recovery nenhuma… Já experimentaste fazer novo download e gravar de novo no cartão com o etcher…


(Luis Alves) #122

Sim já testei varias versões e todas dão o mesmo erro.


(Luis Coelho) #123

Bom dia,

Neste momento corro o HomeAssistant num RPI 3b+ mas como o uso com vários fins ele está a chegar ao limite (librelec com docker:HA+Mosquitto+Grafana+InfluxDB+Portainer+Tvheadend e mais 2 ou 3 containers) não por processamento mas por memória. Ele funciona, mas de vez em quando tenho de lhe fazer um reboot.

Tenho uma Minix X8h plus parada e ao ler este tópico pensei que poderia ser uma solução. Esta box é uma S812. Existe o Armbian para ela.
Alguém sabe se existe o hassio para esta arquitetura ou se algum dos existentes é compatível?
Muito obrigado desde já!


(Nuno Neves) #124

Em princípio o script de instalação para o raspberry pi deve funcionar para essa arquitectura - podes encontrá-lo no tópico “de hass.io para raspassio”…


(Luis Coelho) #125

Muito obrigado @Maddoctor pela dica! vou testar e depois deixo feedback.


(Bruno Melo) #126

Boas, estou a tentar meter o armhassio numa mecool m8s pro w.
Já tentei de tudo sem sucesso… Será que me está a escapar algo??? Simplesmente não arranca do ecrã mecool
Alguma dica?