Bom Hardware relação Consumo/Performance


(Nuno Neves) #21

Mandaste por DHL?! Estás tramado! Pára na alfândega de certeza!


(Ricardo Reis) #22

A mandar vir do site deles é a única opção. Teve de ser, como era faturado pensei que não tivesse que pagar o IVA e estava tranquilo mas afinal a fatura não inclui essas taxas.


(Ricardo Reis) #23

Chegou-me hoje o odroid, até agora parece-me impecável. É pequeno e robusto. Vamos ver como se comporta em questão de performance


(Rodolfo) #24

@ricreis394 instalaste o homeassistant nisso como?


(Ricardo Reis) #25

@RodolfoVieira Ainda não instalei, chegou-me hoje e ainda não tive tempo de fazer isso. A ideia é meter distro baseada em debian/ubuntu e meter hassio através de docker.
Vou usar eMMC invés de SD Card que está na imagem ao lado direito.


(Rodolfo) #26

Ok @ricreis394 eu e o @Maddoctor fizemos parecido , mas usamos uma box android onde temos uma distro debian com o hassio a correr em docker.


(Ricardo Reis) #27

O @Maddoctor mencionou e sugeriu isso no inicio da conversa, mas deu-me mais confiança a compra do Odroid. Vamos a ver :smiley:


(Rodolfo) #28

Vai correr bem, certamente :wink: Depois conta nos os resultados!


(Ricardo Reis) #29

@ricain optei o OS dietpi, mas está a dar-me problemas a instalar o Hassio

Seguindo o exemplo no site do HA.
Instalei os pre-requisitos
Quando chegou à parte deste código

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install" | bash -s

em vez disso, eu fiz

wget https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install
sudo chmod +x hassio_install
sudo ./hassio_install -m odroid-xu

Até aqui nada deu erro, correu tudo bem.
Tento aceder pelo browser e nada. Vou aos logs do container e pelos vistos ele está a tentar fazer pull do home assistant de uma tag que não existe

19-01-10 00:27:55 INFO (SyncWorker_3) [hassio.docker.interface] Pull image homeassistant/armhf-homeassistant tag landingpage.
19-01-10 00:27:57 ERROR (SyncWorker_3) [hassio.docker.interface] Can't install homeassistant/armhf-homeassistant:landingpage -> 404 Client Error: Not Found ("manifest for homeassistant/armhf-homeassistant:landingpage not found").
19-01-10 00:27:57 WARNING (MainThread) [hassio.homeassistant] Fails install landingpage, retry after 60sec

Está num ciclo e não faz mais nada.
Sabes ajudar? Passaste pelo mesmo? Ou apenas instalaste o Homeassistant sozinho?


(Jorge Assunção) #30

Esse script está feito para instalar o HA num Rpi 3B ou 3B+ por isso não vai funcionar noutro equipamento.


(Ricardo Reis) #31

Olha que não, se analisares o script reparas que está preparado para várias arquitecturas. Aliás, foi através desse script que instalei no meu Dell com o Ubuntu.
E no script menciona lá a arquitectura do odroid xu4


(Jorge Assunção) #32

Tens razão, fiz confusão com o do Hassio para raspbian feito pelo dale3h.

Pelo erro parece ser um ficheiro indisponível ou erro de ligação. Tenta daqui a umas horas correr novamente o script.


(Ricardo Reis) #33

A tag que ele está a tentar puxar é a landingpage.
Ao fazer a busca dessa tag na imagem no docker hub, ela não existe. E parece que isto já aconteceu a muito pessoal, mas curiosamente todos desistiram por não conseguir resolver.
A tag que devia de aparecer era a latest


(Jorge Assunção) #34

E se editares o script e alterares todas as ocorrências de landingpage para latest?


(Ricardo Reis) #35

É isso que estava a tentar fazer mas não está no script.
O script só faz referência ao container do hassio. Possivelmente, através do container do hassio ele vai buscar o do home assistant


(Jorge Assunção) #36

Se já é o container do Hassio então o Supervisor já está a correr. O problema agora poderá estar no teu SO. Tenta instalar outro SO e correr o script para despistar o problema.


(Ricardo Reis) #37

A mim parece-me ser uma incompatibilidade do hassio para esta arquitectura especifica. Porque a tag landingpage existe para outras arquitecturas.

A imagem do raspberrypi3, qemux86-64, intel-nuc, etc tem o landingpage
A imagem do armhf e a do aarch64 por exemplo não tem


(Jorge Assunção) #38

Se o problema fosse de uma incompatibilidade entre o Hassio e essa arquitetura o @ricain não tinha conseguido instalar no dele…


(Ricardo Reis) #39

ele instalou mesmo o Hassio ou foi o home assistant sozinho? Porque quase de certeza que consigo instalar o home assistant se chamar pela tag latest.
O problema é que para esta arquitectura o hassio está a chamar a tag landingpage


(Jorge Assunção) #40

Foi Raspassio (Raspbian + Docker + Hassio) mas penso que teve de fazer uma modificação no script.