Broadlink RM PRO


(Rodolfo) #21

Estão na mesma divisão esses AC’s?


(André Cruz) #22

Alguem tem isto a trabalhar com o HA ?

Não consigo ler as frequencias RF com o HA.

Testes feitos :

ler/clonar IRDA com a aplicação ofical - funciona sem problemas
ler/clonar RF com a aplicação ofical - funciona sem problemas

ler IRDA com o HA - funciona sem problemas
ler RF com HA - ERRO : Broadlink switch - Did not received any signal

Para ler as freq. RF no HA usei o mesmo metodo que para ler as freq IRDA.

Se alguem conseguir dar uma dicas, agradeço.


(André Cruz) #23

Para quem possa ter problemas a ler os codigos por IRDA ou RF:
Usei a aplicação cujo link deixo abaixo:

O codigo é representado em texto de letras amarelas.

Deixo tb aqui a programação para uma tomada RF.

  - platform: broadlink
    name: "tomadaSTB"   
    icon: mdi:power-socket-eu  
    # rm2_pro_plus
    timeout: 15
    host: 192.168.1.77
    mac: "33:AA:34:DD:A7:77"
    switches:
      ac_power:
        friendly_name: "tomadaSTB"
        command_on: 'shQ0AAkmCSYJJgkmCSYJJgkmIA8JJiAPCSYJJgkmIA8KJgknCSYgDwkmIA8JJiAPCSYgDwkAAWkAAAAA'
        command_off: 'shs0AAkmCSYJJgkmCSYJJgkmIA8JJiAPCSYJJgkmIA4KJgkmCSYgDwkmIA8JJiEPCSYKJgkAAWgAAAAA'

E depois temos só de criar o switch.
Neste caso tenho o switch com o nome tomadaSTB.

group:

  quarto:
    view: yes
    name: Quarto
    entities:
      - group.quartogroup

  quartogroup:
    control: hidden
    name: Quarto
    entities:
      - switch.tomadaSTB

(Tiago Marques) dividir este tópico #24

2 mensagens foram divididas em um novo tópico: Broadlink Pro e ar condicionado


(Lucas) #25

realmente parece que pela posição dos aparelhos de ar condicionado não tem como enviar sinal para os dois ao mesmo tempo
tem algum extensor externo que seja compativel com o broadlink rm pro?


(André Cruz) #26

Não, tenho mais nenhum sensor, apenas controlo o que está ao alcance dos infravermelhos.


(Augusto Carlos) #27

Boa noite, amigo sabe se clona motor rossi?

Ja tente de tudo que forma e nada.


(André Cruz) #29

Bom dia,
Não conheço o motor rossi.
Isso trabalha por IRDA ou RF ?


(Márcio Andrade) #30

RF, também não estou conseguindo clonar o controle do motor da Rossi


(Rodrigo Picoli) #31

Ola tenjo um Broadlink e gostaria de saber se da para acionar o sonoff por wifi?.. Sem ser por RF.


(Nuno Neves) #32

Se queres accionar por Wi-Fi porque é que perguntas num tópico de rf?!
Por favor respeita as regras do fórum e, neste caso, os assuntos dos tópicos. Se não encontras um que se adeque, cria um novo… Mas para a tua duvida, uma pequena procura será certamente esclarecedora!


(André Cruz) #33

Olá @Rodrigo_Picoli , O sonoff é adicionado por wifi, não vai usar o broadlink.


(Helder) #34

Boas, comprei um Sonoff Bridge mas não funciona nos meus portões.
Curioso que pensei que dava, pois no Broadlink funciona lindamente.
Alguém já testou em motores Proteco Meko ou Libra plus num sonoff bridge?
Até pensei que o Protecto fosse rolling code, mas se aqui afirmam que o Broadlink não dá rolling code!!!
Bem já não percebo nada!


(Nuno Neves) #35

Pode dar-se o caso de que o protocolo não esteja implementado no bridge… Tens o bridge com tasmota ou firmware original?


(Guga Machado de Carvalho) #36

O Sonoff Bridge não consegue “ler” controles remotos e sensores rolling code.

Eu tenho sensores de abertura da Broadlink, que funcionam com o Alarme S1, e o Sonoff Bridge não reconhece o sinal. Já nunca testei no RM da Broadlink apesar de também utilizar ele, mas por enquanto fora do HA.

No Sonoff Bridge somente consegui usar sensores 433 Mhz two way e nunca consegui cadastrar um controle remoto.

Abraço,


(Guga Machado de Carvalho) #37

Caros,

Estou com um problema o qual eu não estou conseguindo fazer o meu Broadlink RM Pro aparecer para aprender os comandos dos controles remotos. Ele está dando o seguinte erro quando você chama o serviço broadlink.learn

“Falha ao chamar o serviço broadlink/learn. required key not provided @ data[‘host’]”

Não consigo compreender o que está havendo.

A programação no config.yaml é esta:

 switch:
 #### BROADLINK RM PRO
  - platform: broadlink
    host: 192.168.0.176
    mac: 'B4:43:0D:XXXXX'
    timeout: 15
    switches:
      # Alarm S1:
      alarm_s1:
        friendly_name: "Alarm S1"
        command_on: ' '
        command_off: ' '

Abraços,


(Nuno Neves) #38

Ao chamares o serviço, precisas de indicar o IP do broadlink usando a chave host:
{“host”: “192.168.0.176”}


(Nuno Mota) #39

Boas. Estou com o mesmo problema que o @guga_carvalho.
Já experimentei chamar o serviço indicando o IP do broadlink, conforme sugeriu o @Maddoctor mas quando coloco lá o IP dá o erro: Invalid JSON.


(MRodrigues) #40

Confirma que foi colocado com as aspas e confirme descrito acima porque tem de ser formato JSON válido.


(Nuno Mota) #41

Obrigado. O problema estava nas aspas. Tinha feito copy/paste da chave host do post do @Maddoctor mas aquelas aspas são diferentes. Apaguei-as, coloquei de novo e já funcionou. Ou melhor, o formato JSON já está correto mas quando chamo o serviço dá o erro: "Falha ao chamar o serviço broadlink/learn.‘192.168.0.XXX’.