Como configurar o componente GeoCode


(Rodolfo) #1

:bookmark_tabs: Como configurar o componente GeoCode
(Carlos Alberto Martins) #2

Nao entendi oq devo colocar dentro da pasta CUSTOM ??


:bookmark_tabs: Como configurar o componente GeoCode
(Rodolfo) #3

@CarlosMartins
Fizeste bem em alertar o post tinha um erro.
O que deves por dentro da pasta config/custom_components/sensor é ISTO


(Carlos Alberto Martins) #4

Estou com um problema, o endereço mostrado não é o correto ( ele fica a mais de 1 quarteirao de distancia).
Mas o endereço certo esta no campo: FORMATTED ADDRESS


(Rodolfo) #5

Nesse caso farias o seguinte:

Dentro do teu configuration.yaml colocarias na parte do sensor

 sensor:
   platform: template
   sensors:
     estado_beto:
       friendly_name: 'Estado actual do Beto'
       value_template: > {{ states.sensor.beto.attributes["Formatted Address"] }}

e depois no teu groups.yaml colocarias

- sensor.estado_beto


(Carlos Alberto Martins) #6

esta dando erro de configuracao nessa linha:

value_template: > {{ states.sensor.beto.attributes["Formatted Address"] }}


(Rodolfo) #7

tira essa > a seguir ao value_template:
ficará assim: value_template: {{ states.sensor.beto.attributes["Formatted Address"] }}


(Carlos Alberto Martins) #8

continua dando erro na mesma linha.
nao teria ASPAS nessa linha ?


(Rodolfo) #9

Verifica assim: value_template: '{{ states.sensor.beto.attributes["Formatted Address"]}}'


(Carlos Alberto Martins) #10

Funcionou tudo ok obrigado.


(Rodolfo) #11

@CarlosMartins coloca um visto no post que resolveu o teu problema.


(Carlos Alberto Martins) #12

Como o post não é meu, acho q por isso, não aparece essa opção para mim.
Não fui eu q abri o tópico.


(Rodolfo) #13

E ao lado sa seta onde fazes responder não tens … 3 pontos? Clica aí e ve se aparece sff.


(Marco Ervões) #14

Ao verificar a minha config aparece o eguinte:

Configuração inválida
Platform not found: sensor.google_geocode


(Jorge Assunção) #15

E o ficheiro .py está no sitio correcto?

custom_components/sensor/google_geocode.py


(Marco Ervões) #16

Faltava colocar dentro da nova pasta “sensor” dentro a “custom_components” vou testar


(Paulo Santos) #17

Boas.
a mim aparece me o mesmo erro, conseguiste resolver?
Configuração inválida
Platform not found: sensor.google_geocode

tenho o ficheiro colocado na pasta config:
custom_components/sensor/google_geocode.py

sensor.yaml

- platform: google_geocode
name: paulo
origin: device_tracker.paulo 
options: street_number, street, city
display_zone: show
api_key: AIzaSyCOxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Home Assistant
0.68.1


(Rodolfo) #18

@pajorge1 tens que colocar o ficheiro que sacaste dentro da pasta config/custom_components/sensor


(Paulo Santos) #19

Boas Rodolfo.
sim ja la esta o ficheiro google_geocode.py


(Jorge Assunção) #20

A formatação do ficheiro está errada.

- platform: google_geocode
  name: paulo
  origin: device_tracker.paulo 
  options: street_number, street, city
  display_zone: show
  api_key: AIzaSyCOxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx