Como configurar o Telegram e interagir com as próprias notificações


(Rodolfo) #21

Basicamente para o mesmo, mas mais virado para receber notificações.


(Jorge Assunção) #22

Isso é o basico. Também uso para receber imagens das câmaras de segurança


(Nuno Freire) #23

Boas, já li e re-li este tópico umas quantas vezes… e vi o vídeo mais de 1000 vezes e continuo a não receber notificações…
O bot está criado, e configurado nada…

Configuration.yaml

# Notificações
notify: !include notify.yaml

#telegram boot
telegram_bot:
  - platform: polling
    api_key: 5779xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxgv6eCo
    allowed_chat_ids:
      - 49xxxxx74

notify.yaml

name: telegram
platform: telegram
chat_id: 49xxxxxxxxxxx4

Automação

#Telegram
- alias: teste
  trigger:
    platform: state
    entity_id: sensor.porta
    to: 'ABERTA'
  action:
     - service: notify.telegram
       data:
         title: 'Porta Aberta'
         message: 'A Porta foi Aberta'
         data:
            photo: 
               - file: /tmp/snapshot_1.jpeg
               - file: /tmp/snapshot_2.jpeg
               - file: /tmp/snapshot_3.jpeg
               - file: /tmp/snapshot_4.jpeg
               - file: /tmp/snapshot_5.jpeg
               - file: /tmp/snapshot_6.jpeg

Alguma Dica do que pode estar mal?


(Jorge Assunção) #24

E erros no log há?

O código do telegram_bot tem os espaços certos? No código que publicaste não estão.

A formatação no notify.yaml está certa? O que publicaste não está.

Se não publicares o código formatado como deve de ser não te podemos ajudar…


(Rodolfo) #25

@nfreire caso possas coloca o código conforme o Jorge disse ou coloca no hastebin.com e coloca aqui o link.


(Nuno Freire) #26

@j_assuncao e @RodolfoVieira Rodolfo… Já ajudaram, o problema estava mesmo no alinhamento do telegram_bot, as vezes o erro está mesmo a frente do nariz e não o vemos

Muito Obrigado!!


(Jaime Silva) #27

Boas… a terceira notificação não funcionou… podem-me ajudar?
https://hastebin.com/fesuvawiqo.bash


(Jorge Assunção) #28

@jagsilva, se não publicares o código com os espaçamento correcto não te podemos ajudar. Selecciona o texto e clica no ícone </>

Podes ler a nossa FAQ aqui.


(Sérgio Lopes) #29

Boa tarde,
Segui todos os passos do Tutorial, mas estou com dificuldades em colocar o Telegram a funcionar.
Já testei de “milhentas” formas e nada…
No meu configuration.yaml coloquei o seguinte:

notify:
  - platform: telegram
    name: telegram
    chat_id: 4XXXXXX0
    
telegram_bot:
  platform: polling
  api_key: 5XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXcc
  allowed_chat_ids:
    - 4XXXXXX0

(Rodolfo) #30

Quando dizes nada…o que é nada? Quais são as automações que estás a usar?


(Jorge Assunção) #31

E podes publicar o teu log para ver-mos os erros que aparecem?


(Sérgio Lopes) #32

Olá @RodolfoVieira e @j_assuncao já resolvi o problema.
Em primeiro lugar, havia um espaço a mais e depois um conflito qualquer com o automatismo.
Refiz tudo e funcionou. Já tenho o HA a responder aos comandos do telegram
Obrigado mais uma vez.
Abraço


(Jorge Assunção) #33

Ainda bem que está resolvido! Onde estava o espaço a mais?


(Sérgio Lopes) #34

Eu acho que não era no configuration.yaml.
Acho que era no automatismo dos combustíveis. Andei a alterar um pouco o exemplo que o Rodolfo postou no post dos combustíveis e devo ter alterado algo.
Depois de refazer, fiquei com o o Telegram a funcionar e sem erros no automatismo dos combustíveis.
Abraço


(Renato Barbosa) #36

Agora não funciona automação. O que tenho feito de errado ?

config yaml

notify:
  - name: telegram
    platform: telegram
    chat_id: 4186

telegram_bot:
  platform: polling
  api_key: 577
  allowed_chat_ids:
    - 4186

teste:

yaml de automacao

- id: '1529203213762'
  alias: teste2
  trigger:
  - entity_id: input_boolean.sonoff_switch_2
    from: 'off'
    platform: state
    to: 'on'
  condition: []
  action:
    - service: notify.telegram
      data:
        message: 'Iluminação da Cozinha Ligada'

log

Error sending message: Chat not found. Args: (4186, 'teste\nIluminação da Cozinha Ligada'), kwargs: {'parse_mode': 'Markdown', 'disable_notification': False, 'disable_web_page_preview': None, 'reply_to_message_id': None, 'reply_markup': None, 'timeout': None}

RESOLVIDO… DESCULPA!!!
Eu tinha pegado o o ID errado.


(Jorge Teixeira) #37

nao tem os exemplos :frowning:


(Rodolfo) dividir este tópico #38

4 mensagens foram divididas em um novo tópico: Notify para IOS (sem depender de terceiros)


(Joao) #39

Ok obrigado na mesma!


(Douglas Machado Baptista) #40

Olá, eu consegui fazer funcionar uma vez. Mas agora não consigo de jeito nenhum.

Apaguei o bot e criei um novo para começar do zero. Então ao criar o bot, quando coloquei uma mensagem no bot criado, a url (https://api.telegram.org/botTOKEN/getUpdates) que acessei mostrou isso:
Conflict: terminated by other getUpdates request; make sure that only one bot instance is running

Não sei como resolver.


(Rodolfo) #41

@Douglas mas não consegues obter o chat id?