Como flashar um Sonoff Basic com Tasmota


(Pedro Batista) #42

e são iguais nos dois locais


(Nuno Neves) #43

Tem que ser iguais nos 3 locais… Mosquitto, tasmota e home assistant…
E no tasmota o mqtt host está correcto?! Tem de ser o IP do broker, neste caso, o do raspberry…


(Pedro Batista) #44

Quando diz o IP do broker será o mesmo IP com que acedo ao HA correto?


(Jorge Assunção) #45

@PedroBatista quando publicares código, selecciona o texto e clica no ícone </>


(Pedro Batista) #46

Registado :wink:
Obrigado


(Rodolfo) #47

Sim , certo é isso mesmo.


(Pedro Batista) #48

Então neste momento tenho assim:
HA:

    mqtt:
      broker: 127.0.0.1
      port: 1883
      username: cloudmqttuser
      password: cloudmqttpassword
      keepalive: 60
        
switch:
  - platform: mqtt
    name: "sonoff"
    state_topic: "stat/sonoff/POWER"
    command_topic: "cmnd/sonoff/power"
    availability_topic: "tele/sonoff/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    payload_on: "ON"
    payload_off: "OFF"
    retain: true    

Mosquitto:

{
  "plain": true,
  "ssl": false,
  "anonymous": true,
  "logins": [
    {
      "username": "cloudmqttuser",
      "password": "cloudmqttpassword"
    }
  ],
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

Tasmota:

mesmo que no HA altere o broker não funciona


(Rodolfo) #49

no addon do mosquitto, deste Start? e no group chamaste esse switch?


(Pedro Batista) #50

Start estava ok
No group não tinha chamado.
Se eu não colocar nada no group a minha visão geral é assim

Se colocar o seguinte no group.yaml a minha visão geral fica sem nada :frowning:

default_view:
  view: yes
  icon: mdi:home
  entities:
    - switch.sonoff

(Nuno Neves) #51

No tasmota está o IP errado do broker… Qual é o IP do raspberry pi?


(Pedro Batista) #52

O ip do rasp ]e o que esta no tasmota


(Jorge Assunção) #53

Podes publicar o teu ficheiro configuration.yaml? Tens mais algum equipamento a funcionar por MQTT?


(Pedro Batista) #54

Nao tenho mais nenhum equipamento por MQTT, este e o primeiro.

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 41.2357
  longitude: -8.6199
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Lisbon
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
#introduction:

# Enables the frontend
frontend:
  #development_repo: <absolute path to home-assistant-polymer>

# Enables configuration UI
config:

http:
  # Secrets are defined in the file secrets.yaml
  api_password: 
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:


# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Weather prediction
sensor:
  - platform: yr

# Text to speech
tts:
  - platform: google

# Cloud
cloud:

#Xiaomi Gateaway
xiaomi_aqara:
  discovery_retry: 5
  gateways:
    - host: 192.168.1.83
      mac: 34:CE:00:88:C2:1B
      key: 8hqz1jd8x8hbyp7m
      
#efergy
sensor 2:
  - platform: efergy
    app_token: 26lRpGBc8IHNnC5rd0HhUUxXWfGjXeMo
    utc_offset: 0
    monitored_variables:
      - type: current_values
      


#Sonoff
mqtt:
  #broker: 127.0.0.1
  broker: 192.168.1.102
  port: 1883
  username: cloudmqttuser
  password: cloudmqttpassword
  keepalive: 60
  
  
switch:
  - platform: mqtt
    name: "sonoff"
    state_topic: "stat/sonoff/POWER"
    command_topic: "cmnd/sonoff/power"
    availability_topic: "tele/sonoff/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    payload_on: "ON"
    payload_off: "OFF"
    retain: true    



history_graph:
## Consumos Diários
    graph_daily_consumption:
        name: Consumos Diários
        entities:
        - sensor.efergy_650502
        hours_to_show: 48
        refresh: 30





group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

(Rodolfo) #55

@PedroBatista pelas imagens que vi, tu estas a definir no configuration.yaml o mqtt server como 192.168.1.102, e no tasmota tas a definirrr 192.168.1.101 isso ta mal. Tens que colocar em ambos o ip do teu pi onde esta a correr o mqtt.


(Pedro Batista) #56

Tens toda a razao @RodolfoVieira agora sim funciona :slight_smile:
Quem sabe sabe.
Obrigado pela ajuda de todos.


(Nuno Neves) #57

Era o que te tinha dito acima e tinhas dito que estava correcto… :wink:


(Pedro Batista) #58

Tens razão @Maddoctor :wink:


(Tozé Pereira) #59

Como criar um script que ligue e desligue um interruptor e envie a notificação via Pushbullet?

Para o script básico estava a tentar:

printer_on:
  sequence:
- service: mqtt.publish
  data_template:
  topic: "cmnd/sonoff108/power"
  payload: 'ON'

E pushbullet:

- alias: Notify on 3D Printer Switch Turn Off
  trigger:
  - platform: state
    entity_id: sonoff108
    from: 'on'
    to: 'off'
  action:
  - service: notify.pushbullet
    data:
      message: 3D printer Switch turned off
      title: 3D Printer

No script apesar de salvar sem erros, ao iniciar o Hassio dá-me este erro:

Invalid config

    The following components and platforms could not be set up:

        script

    Please check your config.

Obrigado


(Jorge Assunção) #60

O script tem o espaçamento mal feito. É assim que tens no teu HA?


(Tozé Pereira) #61

Vejo tantas soluções diferentes na internet que chega a ser frustrante :expressionless: especialmente porque a cada teste tenho de reiniciar o Hassio e como é num RPI0 ainda demora um pedaço…