Como integrar o aspirador da Xiaomi no HA


(Hugo Silva) #21

Será que estou a fazer confusão e o token é só mesmo isto?


(Jorge Assunção) #22

@RodolfoVieira, coloca umas capturas de ecrã para se perceber melhor.


(Rodolfo) #23

@Hugo_Silva tu nao precisas do mitoolkit para nada… tu viste o video : https://www.youtube.com/watch?v=XGUdE-QZcKo
Tens ai como tirar o token… acho que estás um pouco perdido. vê o vídeo e vais conseguir.

Esta é a configuração que tens que por no teu configuration.yam

vacuum:
  - platform: xiaomi_miio
    host: 192.x.x.x
    token: aqui colocas o token dos 32 caracteres que viste na app
    name: Aspirador

(Hugo Silva) #24

Obrigado @RodolfoVieira não tinha percebido que não precisava do Mitoolkit. Já o descobri. Agora vou inventar um bocado.

Obrigado mais uma vez a todos pela ajuda.


(Rodolfo) #25

@Hugo_Silva tens ai toda a configuração no 2º Post 📑 Como integrar o aspirador da Xiaomi no HA :wink: é so adaptares as tuas necessidades, :slight_smile: fico contente por te funcionado não precisas de agradecer mas la em cima do teu browser tens o icone do paypal ajuda nos :wink: ehehhehe


(Carlos Sebastião) #26

@RodolfoVieira resumindo,

já tenho o token.
agora esse codigo todo coloca-se onde?


(Rodolfo) #27

@Carlos_Sebastiao no post acima do teu a resposta que dei ao Hugo serve para ti


Aspirador Xiaomi como aspirar zonas específicas da casa
(Gonçalo C.) #28

@RodolfoVieira, ali no teu código defines o sensor estado_aspirador, e ao longo do código mais abaixo referes-te ao mesmo como estado_do_aspirador.

E na linha de código referida abaixo falta uma “{” para o parametro cleaned_area.
message: "Olá o Chinês acabou de acabar o seu serviço de aspiração esteve {{states.vacuum.aspirador.attributes.cleaning_time }} minutos a aspirar, e aspirou {{states.vacuum.aspirador.attributes.cleaned_area }} m2. Está com {{states.vacuum.aspirador.attributes.battery_level }} de bateria. Ele está neste momento a regressar à base."

Andei para aqui a bater com a cabeça porque não recebia a notificações do telegram e lá descobri que era isso :grin:


(Pedro Rocha) #29

Estou com o mesmo problema não aparece só o nome e o ip. Pela mihome v5 ao tentar abrir o setting ele não abre e bloqueia as opções


(Marco Pinheiro) #30

Boa tarde a tod@s,

O meu HA fica sempre meio baralhado em relação às coordenadas anotadas nas definições. Da primeira vez, quando o mando aspirar uma zona, ele vai e faz tudo. Depois daí a uns dias se tentar novamente, ele sai da base e volta logo a seguir… Já recriei as coordenadas todas novamente (trabalheira, são várias as divisões) e acabei outra vez por ficar com o aspirador meio desorientado :slight_smile:

Alguma dica ou ideia do que possa estar a fazer de errado?

Obrigado!


(Pedro Rocha) #31

já consegui usei a versão 5.0.29 do mi home


(Rodolfo) #32

Estranho, não tiraste a dock do sitio pois não?


(Marco Pinheiro) #33

Pois, foi isso que imaginei que pudesse ter acontecido (sei lá, ter-se movido uns centímetros) e voltei a aspirar a casa toda, e a fazer novas zonas. Ao fim de um ou dois dias, puf… baralhado de novo :frowning:


(Rodolfo) #34

Só testando novamente, para ver se volta a fazer a mesma coisa, mas para nao teres muito trabalho define apenas duas zonas… para ver se ele volta a fazer o mesmo.


(João Ferreira) #36

Bom dia,

Uma vez configurado, é normal aparecer informação “Unknown”?

image

Eu dividi o código do @RodolfoVieira da seguinte forma:

xiaomi_vaccum.yaml

  • vacuum info
  • sensors
  • input select

groups.yaml

  • group

automations.yaml

  • automations (sem a parte de enviar mensagens via telegram)

(Bruno Melo) #37

Boas malta, e em especial @RodolfoVieira. Comprei o roborock S55 e instalei a mi home modificada que está no teu toturial mas não consigo ter acesso ao mesmo. Já consegui anteriormente tirar os token das lâmpadas Philips zhirui mas agora do aspirador não estou a conseguir. Pede para atualizar a app. Aparentemente só não funciona com o aspirador, pois consigo ver o token das lâmpadas. Eu tive de configurar no servidor europeu, será que se adicionar no mainland funcionará? Será que haverá alguma alternativa? Muito obrigado


(Pitoganzado) #38

Boa noite @RodolfoVieira ! Podes partilhar a tua actual configuracao do aspirador? muito obrigado


(Rodolfo) #39

@pitoganzado

https://hastebin.com/yekajugiza.coffeescript


(Pitoganzado) #40

@RodolfoVieira muito obrigado!
o input_select dos locais de aspiração estão a funcionar? no meu caso nao faz nada.
Abraço


(Rodolfo) #41

Sim estão a funcionar.