Como publicar os preços dos combustíveis no seu Home Assistant


(João Cosme) #21

já fiz com essa tua nova versão. Depois quando executo o código, não acontece nada. O ficheiro é suposto ficar na localização do ficheiro fuel.info.sh certo? nao gerou nenhum ficheiro…


(Rodolfo) #22

Não @ricard0g0mes não falta.


(Bruno Lopes) #23

no meu está tudo a funcionar excepto quando corre automaticamente.

Tenho o erro:

ERROR (MainThread) [homeassistant.components.shell_command] Error running command: bash /home/homeassistant/.homeassistant/www/fuel.info.sh -f "181***", return code: 1
NoneType: None

Se executar manualmente ele actualiza


(Ricardo Silva) #24

A mim tentei mas não resultou não me cria os sensores, depois de fazer o comando mais acima para debug fiz o curl manual:
curl -s -X POST -H 'x-ha-access: minhapassword' -H 'Content-Type: application/json' -d '{"state": "1.354", "attributes": {"unit_of_measurement": "€", "icon": "mdi:gas-station", "friendly_name":"Gasoleo simples (OLIVAL BASTO)"}}' https://meuip:8123/api/states/sensor.fuel_170157_Gasoleo_simples

Mas mesmo assim nada e não dá erro nenhum.


(Álvaro M. Ferro) #25

O ficheiro fica no sítio onde tiveres chamado o fuel.info.sh


(Álvaro M. Ferro) #26

Aqui já não sei ajudar. :sweat_smile:


(Álvaro M. Ferro) #27

Vai ao <> no HA e vê lá se ele os criou em fuel. Esse post para o HA está correto.


(João Cosme) #28

Não dá… eu envio o comando, mas não cria nenhum ficheiro… não sei se estou a fazer algo mal


(Jorge Assunção) #29

Que versão do HA tens? isso pode ser um erro de permissões.


(João Cosme) #30

Tenho a ultima @j_assuncao. As permissoes do ficheiro tão dadas (755). É preciso algo mais?


(Jorge Assunção) #31

Hassio, Hassbian, Raspbian…?


(João Cosme) #32

ah, Hassio… O @RodolfoVieira também tem o Hassio e a ele funciona…


(Ricardo Gomes) #33

2018-05-10 14:33:32 ERROR (MainThread) [homeassistant.components.shell_command] Error running command: bash /config/script/fuel.info.sh -f "181184 185055 184639", return code: 7
NoneType: None

:frowning:


(Ricardo Gomes) #34

a mim também não cria nenhum ficheiro.
Tenho tb permissões 755


(Rodolfo) #35

@ricard0g0mes diz me qual é a versão do github que estas a usar? e em vez de testares os teus postos de gasolina testa este comando no teu putty

bash /config/script/fuel.info.sh -f "170157"

E verifica se nos teus entities já te aparece algo quando pesquisas por fuel tipo isto:

Está me a fazer um pouco de confusão estares a usar o mesmo sistema que eu tal como o @joaocosme e isso não estar a bombar.


(Álvaro M. Ferro) #36

A primeira versão não tem debug. Por isso, a flag -d não vai fazer nada.

Se executares o comando com bash fuel.info.sh -f “170157” não tens de te preocupar com permissões.

Se não der nada e estás a usar a versão mais recente, faz bash -x fuel.info.sh -d “170157” e envia-me o resultado.

Se estiveres a usar a primeira versão, faz bash -x fuel.info.sh -f “170157” e envia o resultado.

-x é a instrução de debug da bash.


(Jorge Assunção) #37

E em que pasta estás a correr isso?


(Jorge Assunção) #38

Para que não consegue correr o script, tentem o seguinte: dentro do ficheiro configuration .yaml criem a directiva whitelist_external_dirs ao mesmo nivel da timezone de modo a que fique assim:

## TIME_ZONES
  time_zone: Europe/Lisbon
## WHITELIST
  whitelist_external_dirs:
    - /config/cam_snapshots

Onde está /config/cam_snapshots alterem para a pasta onde está o script. Reiniciem o HA (não façam reload do core, precisa reiniciar totalmente) e quando estiver de novo a funcionar testem novamente o script.


(Ricardo Silva) #39

É isso mesmo, não me aparece os sensor.fuel…

Queres que faço algo de diferente?
Tenho hassbian (ambiente virutal) + ha 0.68.1


(Bruno Lopes) #40

No meu caso nao resolveu… se for manualmente o script, pelo HA não.