Configuração do HA

OK vamos lá.
Instalei o HA em uma raspiberry pi 3B+.
Consigo acessar o HA no seguinte endereço: http://hassio.local:8123

configurei o mqtt mosquito broker.

e para a minha primeiro controle, escolhi o exemplo da página de documentos do HA:

consegui compilar o código e gravar no nodemcu.

pelo status do nodemcu e do broker posso ver que o node mcu se conectou com sucesso ao broker.

21:32:12.617 -> INFO: Connecting to minha-rede
.......
21:32:16.099 -> INFO: WiFi connected
21:32:16.099 -> INFO: IP address: 192.168.xx.xx
21:32:16.132 -> INFO: Attempting MQTT connection...
INFO: connected

1543966336: New connection from 192.168.xx.xx on port 1883.
[INFO] found wilson on local database
1543966336: New client connected from 192.168.xx.xx as office_light1 (c1, k15, u'wilson').

No exemplo tenho que ligar e desligar um led. Mas não aparece nemhum comando para que eu possa fazer isso.

como devo proceder? o quer esta faltando?

esta é a minha configuration.yalm

homeassistant:
  # Name of the location where Home Assistant is running
  name: wilson Home
  # Location required to calculate the time the sun rises and sets
  latitude: 0
  longitude: 0
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: UTC
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Sensors
sensor:
  # Weather prediction
  - platform: yr

mqtt:
  broker: 192.168.15.6
  username: wilson
  password: wilson_big_mqtt
  
  
light:
      platform: mqtt
      name: Office light'
      icon: mdi:lightbulb
      state_topic: 'office/light1/status'
      command_topic: 'office/light1/switch'
      optimistic: false
      qos: 1
      payload_on: "ON"
      payload_off: "OFF"
      payload_available: "Online" 
      payload_not_available: "Offline"
      retain: false
 
    
# Text to speech
tts:
  - platform: google

# Cloud
cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

e esta e a minha groups.yalm

# 1
lights_view:
  view: true
  icon: mdi:lightbulb
  name: Lights
  entities:
  - group.lights
  - group.switches

realmente sou novo com o HA e preciso de ajuda.

obrigado.

@wilson os ficheiros Yaml são muito sensiveis ao espaçamento. A entrada light: tem demasiados espaços, deves ter apenas dois espaços.

Quando eu faço o teste das configuraçãoes o HA não acusa erros.

e sim estou utilizando o espaçamento de dois em dois.

Ufa acabei de desligar e religar o haspberry pi. e vevam o que aconteceu.

ou seja, bastava eu rebootar a rasp que as configurações entraram

obrigado a todos.

Depois de cada alteração aos ficheiros de configuração o HA deves fazer sempre um restart.

Este tópico foi automaticamente fechado 90 dias após a última resposta. Novas respostas não são permitidas.