Configurar tracker


(Guga Machado de Carvalho) #1

Caros,

Me perdoem pela minha pouca experiência. Estou tentando aprender…

Qual o melhor tracker que se pode utilizar (se é que tem mais de um) e como faço para configurar.

Muito grato,


(Rodolfo) #2

@guga_carvalho o que queres fazer exactamente podes ser mais explicito?


(Guga Machado de Carvalho) #3

Boa Noite @RodolfoVieira.

Eu estou com dificuldade em colocar o owntracks para funcionar junto com o mosquitto broker

aqui está a minha config

 mqtt:
  broker: core-mosquitto
  username: ***
  password: ***

  broker: m10.cloudmqtt.com
  port: 10717
  client_id: owntracks
  keepalive: 60
  username: ***
  password: ***

device_tracker:
  - platform: owntracks

O que será que eu estou fazendo de errado…

Abraços,


(Guga Machado de Carvalho) #4

Já tentei de tudo…

Não consegui fazer funcionar nada… Este owntracks não funciona, o gps logger não funciona…

O único que eu consegui fazer funcionar foi o do google maps.

Se alguém tiver alguma opção, eu tento…

Abraços,


(Jorge Assunção) #5

E os brokers estão a funcionar? À primeira vista parece-me que isso está mal configurado.

Dá uma vista de olhos a isto:

E isto:


(Rodolfo) #6

Já exprimentaste o zanzito?


(Nuno Neves) #7

Usa o owntracks por http!


(Guga Machado de Carvalho) #8

Bom dia @j_assuncao.

Eu tentei alguns tutoriais muito semelhantes a este, porém com uma pasta diferente dentro do servidor raspberry.

Teoricamente deveria ter sido mais fácil, visto que eu não tenho problemas com abertura de portas devido a ter uma conexão dedicada com IP fixo real.

Vou tentar hoje estes tutoriais e respondo.

PS: o servidor mqtt está funcionando normalmente, e a configuração já não é esta mais que eu postei aqui.

Um grande abraço,


(Guga Machado de Carvalho) #9

Bom dia @RodolfoVieira.

Esse eu não testei. Vou primeiro tentar os tutoriais passados pelo @j_assuncao e se não der certo, tentarei este.

O Google Maps está funcionando, porém não tem muitas informações.

Um grande abraço,


(Guga Machado de Carvalho) #10

Já tentei, porém não obtive resultado.

Ele tenta comunicação com o servidor, mas o mesmo não responde.

Em seguida disso, eu vi alguns posts na Internet comentando que o serviço de http não estava mais funcionando. Aí acabei desanimando.

Um grande abraço,


(Jorge Assunção) #11

E consegues comunicação com os dois servidores de MQTT em simultâneo?


(Nuno Neves) #12

O serviço http está a funcionar perfeitamente que tenho-o a funcionar…


(Guga Machado de Carvalho) #13

Não, não é possível ter os dois simultaneamente. Mas só descobri isso depois… :grin::grin::grin:

Tanto que a minha configuração está somente com o mosquitto add-on.

Abraço,


(Guga Machado de Carvalho) #14

Tem como depois você postar a sua configuração para eu ver e tentar fazer igual caso o mqtt cloud não funcione…

Abraço,


(Rodolfo) #15

@guga_carvalho em relacao ao owntracks o zanzito embora seja pago, apresenta boas vantagens , tanto que caso queiras ir por esse caminho podes ver um video que demonstro como o configurar.
E em termos de consumo de autonomia é melhor, eu ja usei ambos há muito tempo inclusive o gps logger, e o zanzito é o que apresenta excelentes resultados.
Video aqui: https://www.youtube.com/watch?v=sSU1qpLwbdI


(Guga Machado de Carvalho) #16

@RodolfoVieira, muito obrigado pela atenção.

Estou fora de casa, e assim que chegar vou tentar fazer a configuração.

Independente de ser pago ou não, o que me importa é a qualidade do serviço. Se for bom está valendo.

Abração,


(Guga Machado de Carvalho) #17

@RodolfoVieira consegui instalar o Zanzito seguindo o seu tutorial em vídeo. Espetacular!!! :clap:t2::clap:t2::clap:t2::clap:t2::clap:t2:

Somente no final tive o mesmo erro de um colega aqui do fórum, e arrumei o temolate também. Fiz a compra do Zanzito pago, e depois vou seguir a sua recomendação e pedir outra chave para a minha esposa.

Agora o próximo problema a resolver, é que não consigo de forma alguma instalar o SSH.

Na segunda feira vou entrar em contato com o meu provedor e verificar se a porta 80 e a 443 estão realmente abertas. Pois tentei de tudo e nada.

Meu router é um TP-Link Deco M5 com a configuração bem simples de ser feita.

Vou comentando aqui o progresso.

PS: O meu Zanzito eu não consegui fazer funcionar também na porta 8883 (SSH), só funcionou na 1883. Agora já não sei se isso tem a ver com o fato de que o lets encrypt ainda não está instalado, ou se é outra porta bloqueada.

Abração,


(Guga Machado de Carvalho) #18

@RodolfoVieira, não sei se foi coincidência ou não, mas eu finalmente consegui instalar o duckdns com o plugin do let´s encrypt.

Era uma coisa tão básica que eu nem havia notado que precisava mudar. Coisa de noob. Quando você instala o plugin do Duckdns, ele vem com a opção do SSL desabilitada (false), e para fazê-lo instalar, você precisa habilitar (true). Feito isso funcionou.

O Zanzitto está funcionando perfeitamente dentro da minha rede. Quando desabilito o wi-fi e ele vai para a rede LTE 4,5G, ele perde a conexão.

Isso pode ser por causa do ssl não estar habilitado nele (Zanzitto)?

Como faço para usar com o ssl? Vi que precisa de um cerificado instalado no celular. Como que faço isso?

Abraço,


(Jorge Assunção) #19

Para o Zanzito funcionar fora da rede interna a porta 8883 tem de estar aberta para o exterior e o SSL tem de estar activo no broker MQTT. Estás a usar Hassio?


(Guga Machado de Carvalho) #20

Sim, uso o hassio. Porém se eu coloco o ssl, aí nem dentro da rede WiFi ele funciona.

Mais uma coisa. Ele me pede um certificado ca para colocar no Android, onde eu consigo ele?

Abraços,