Em que hardware instalaram o HA?


(jpm) #42

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=7a26bca4-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait modules-load=dwc2,g_ether

PS: hassbian
Se colocar
bdcc400d-72a3-4b8d-839f-139ec92f223c (do SSD) já não arranca


(Ricardo Silva) #43

O meu esta assim:
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/sda1 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

Faz o seguinte, tambem tive esse problema e mudei para “/dev/sad1”. Para saber qual sdx tens que meter, tens que arrancar via SD com o disco usb inserido e depois escreves esse comando: lsblk

root@raspberrypi:~ # lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda           8:0    0 119.2G  0 disk
-sda1        8:1    0 119.2G  0 part /
sdb           8:16   0    56G  0 disk
-sdb1        8:17   0    56G  0 part

No meu caso é sda1 (o sdb1 é outro disco que tenho lá ligado).


(jpm) #44

Parece que é da destribuição.

Instalei o hassbian e ja arranca do ssd sem problem.

Agora tenho de perceber como é que transito desta versão para o Hass.io/hassos porque embora seja muito bom e muitas coisas ter acesso ao SO para o que é o gui do outro+plugins é excelente.

Obrigado


(Pedro Januário) #45

Caso tenham interesse tem aqui info de como instalar tudo de forma automatica e controlada :slight_smile:


(jpm) #46

Depois de mais um dia despendido, que felizmente neste momento disponho, consegui chegar a uma conclusão “basica”, o HA atraves do nosso os HASSOS não permite a instalação em qualquer outro meio que não seja o sd card, assim sendo lá consegui sacar uma versão deprecated do hass.io e já está a bombar, boot e kernel no ssd.

Obrigado


(Flávio Afonso) #47

Eu já tive HassOS instalado e a funcionar num HDD 2.5" num Pi 3b+.


(Jorge Assunção) #48

Mas com cartão SD, certo?


(jpm) #49

Finalmente um fds para testar as coisas e…algo não está a bater bem:

Com o SSD as respostas/acesso À informação está muito mais rápido :slight_smile:

Contudo fico varias vezes sem rede/parado e isso parece-me que seja de estar a bater no limite do tráfego passível de ser cursado isto porque o interface USB e o eth0 estão interligados.

Mais alguem tem/teve este problema ou é simplesmente coincidência?


(Jorge Assunção) #50

Estás a utilizar ligação fixa (RJ45) ou móvel (Wifi)? E estás a utilizar IP fixo?


(jpm) #51

Estou a usar o RJ-45 e ip fixo sim.

Alguma sugestão para “upgrade”? Quero manter os consumos e o barulho dentro dos mesmos niveis.

Até tenho um NAS com a capacidade de correr dockers mas…ja vi que consigo instalar o Ha mas não Hassio/hassos pelo que talvez tenha de mandar vir um orange/banana/etc pie.

Alguem com um destes que possa dar feedback? (Requesitos: Boot from usb, LAN com bandwidth diferenciada do interface USB, low power, e não menos potente que um rpi3)


(Ricardo Reis) #52

Tenho neste momento um Dell R610 com Proxmox VE, o home assistant está alojado numa VM Ubuntu com docker com hass.io


(MRodrigues) #53

Viva,

Eu acabei de fechar a instalação num Portátil Lenovo T400 que tinha aqui parado. Primeira preocupação foi verificar quanto consumia e cheguei a valores que não imaginava serem possíveis na ordem dos 15-20W. Vou deixar correr um dia inteiro para ver como se porta no consumo total. E vou testar esta tomada medidora de consumo para ver se está mesmo a medir bem.

Estou muito satisfeito com o desempenho (eu tinha um raspberry zero W, portanto qq coisa seria melhor) e agora posso colocar aqui mais carga em cima disto.

Única dúvida é a durabilidade de um portátil a agir como servidor, mas estes Lenovo são umas máquinas de guerra.

Tenho a vantagem de ter ainda bateria e não precisar de UPS e vou ativar uma pen 3G, para enviar notificações em caso de falha de luz.

Tenho um Ubuntu com docker hass.io e só me arrependo de não ter feito já em VM, porque assim fazia snapshot para um disco de rede, caso o portátil avarie (que há de acontecer mais cedo ou mais tarde).

Caso tenham alguma sugestão, será sempre bem vinda!


(Marco Ervões) #54

O meu hassio está instalado num pc antigo que não lhe dava uso, um intel 80386. Rola às mil maravilhas.


(Luís Miguel Andrade) #55

A pouca ventilação, disco mecânico e durabilidade da bateria podem ser a maior preocupação nesse sistema. Podes colocar um ssd, monitorizar a bateria e temperaturas para ficares mais tranquilo com o envio de mensagens.

Com uma imagem do teu atual sistema ou backup podes migrar com facilidade para um ambiente virtual. Contudo, verificava antes as capacidades desse cpu para virtualização. Recomendo o proxmox, caso o hardware suporte.


(MRodrigues) #56

Sou capaz de arranjar uma daquelas bases com ventoinhas para ter alguma ventilação extra. A bateria tem sido uma surpresa pois ainda está a 81% da capacidade.

Infelizmente este modelo não tem sensor de temperatura na bateria (ou não o encontrei), mas dei seguimento à ideia e adicionei agora monitorização nos CPU’s, que será um excelente indicador caso algo corra mal

Text

Eu sempre usei vmware e virtualbox, mas este proxmox parece ser muito interessante. Vou sem dúvida explorar! Obrigado pela dica.


(Luís Miguel Andrade) #57

Recomendo testares o limite da capacidade da bateria para verificar se faz um “graceful shutdown” e se a autonomia não é desequilibrada. Por vezes a indicação de capacidade em baterias antigas podem ser enganadoras em diversas percentagens conforme esgotam (ex: podem dar saltos de 20% para 5% em menos de um minuto… e os mesmos 15% demorar 10 minutos em percentagens superiores)

Para valores de temperatura desses acho que não necessitas gastar dinheiro em ventoinhas. Dificilmente, vais ter picos de temperatura… só eventualmente quando fizeres updates e serão momentâneos. Basta deixares o portátil suportado em pés para elevar o mesmo e não encostar diretamente na mesa, tendo atenção em colocar em local ventilado.

Com tanta RAM livre até podes ter várias VMs ou vários ambientes para fazeres testes se o CPU for compatível. Sendo o disco mecânico, reforço a minha chamada de atenção: os discos de portáteis costumam ter uma durabilidade reduzida, principalmente se trabalharem 24/7… com o peso dos anos o risco aumenta substancialmente, mesmo sendo um IBM :wink:


(Tiago Marques) #58

@Luis_Andrade
IBMish…

@mfrodrigues
Mesmo que não seja espetacular, de certeza que a bateria do T400 é melhor que a do RPI :slight_smile:
O ideal é teres isso em VM para fazer snapshot à VM. Antes de updates e alterações significativas à configuração, não há melhor.

Snapshot Hassio != Snapshot VM :smiley:


(MRodrigues) #59

Já testei a bateria e está com umas incríveis 2 horas de autonomia!!

@tmarquespt , este realmente já não tem nada de IBM :smile: O último penso que foi o T45. Mas eles mantiveram-se fieis na parte da robustez/fiabilidade. Vou seguir a dica da VM sem dúvida!

Possivelmente já fica um pouco off-topic, mas pode haver pessoal com interesse:

Fiz este script (SO: Linux) que passados 90 minutos, faz um graceful shutdown com timeout de 1 minuto a todos os dockers que estiverem a correr e depois desliga o servidor. Falta aqui a parte de enviar uma notificação, portanto estes prints em baixo são inuteis, mas deixei ficar para quanto ativar o Dongle 4G.

#!/bin/bash

if on_ac_power; then
    echo "Power[OK]"
else
    battery_level=`acpi -b | grep -P -o '[0-9]+(?=%)'`
    since=`upower -i /org/freedesktop/UPower/devices/battery_BAT0 | grep time`
    if [ $battery_level -le 90 ]; then
    echo "Critical[NOK] - Bat percentage $battery_level% - shutting down services"
    docker stop --time=60 $(docker ps -a -q)
    poweroff
    exit
    fi
    echo "Power[NOK]: ".$since
fi

(Jorge Assunção) dividir este tópico #60

A post was split to a new topic: Erro a arrancar Hassio por SSD