Erro como addon MQTT Server & Web client


(Sérgio Figueiredo) #1

Acabei de flashar um sonoff com tasmota e queria por a funcionar com o hassio.
Para isso instalei o MQTT Server & Web client mas depois de fazer start dáme erro na porta 4884 e não consigo abrir no browser o configurador.
Para funcionar em MQTT tenho que instalar um MQTT Broker não é? essa instalação resume-se a instalar este Addon ou é preciso mais alguma coisa. Também tentei instalar o Mosquitto MQTT broker mas este nem sequer instala. Depois de clicar em instalar o botão aparece a vermelho e não instala.
Tenho Raspassio instalado.


(Rodolfo) #2

@sergiolf quando tentas instalar o addon Mosquitto Mqtt Broker já exprimenta activar ou desactivar o protection mode e depois tentar clicar em install


(Sérgio Figueiredo) #3



Não tenho esses switch sequer. ao clicar no install fica o botão a vermelho e não faz nada


(Jorge Assunção) #4

@sergiolf
Vamos começar pelo principio.

  1. Qual a versão do HA que tens?
  2. Qual é exactamente o erro que tens com a porta 4884?
  3. Estás a instalar o Mosquitto broker com o MQTT Server & Web Client instalado?

(Sérgio Figueiredo) #5

A instalação que tenho é esta:

1 - A versão é a última (agora não tenho o rasp comigo mas sei que actualizou na sexta feira para a ultima versão). Este problema também acontecia na versão anterior.

Primeiro tentei instalar o Mosquitto broker e não deu, depois instalei o MQTT Server & Web Client que também não consegui abrir o browser para parametrizar (dava este erro: Error: Unable to create websockets listener on port 4884). Entretanto voltei a desinstalar o MQTT server & Web Client.

O que tenho que instalar primeiro é mesmo o Mosquitto broker certo?
Não preciso de instalar nada no Rasp antes de instalar este addon no Hassio?
No Mosquito broker não dá erro nenhum, o que acotece é o botão de instalar mudar para vermolho um instante.


(Jorge Assunção) #6

Desinstala o Mosquito broker e o MQTT Server. Depois reinicia o Rpi e não apenas o HA. Por fim volta a instalar apenas o Mosquito broker. se tiveres algum erro diz qual é para podermos despistar.


(Sérgio Figueiredo) #7

não mostra nenhum erro, é isto que acontece (video):


(Jorge Assunção) #8

Isso tem de ter um erro no log. Procura bem em especial no ficheiro home-assistant.log.


(Sérgio Figueiredo) #9

Não sei qual a razão, mas tentei agora instalar acedendo ao rasp pelo smartphone e instalou.
Logo já vou ver se ponho isso a dar, a comunicar com o sonoff.


(Rodolfo) #10

@sergiolf pode ser problemas de cache. É muito comum haver esse tipo de problemas sim.