Erro na instalação manual do hassio em raspbian


(Lazaro Enes) #1

Boa noite,
caros amigos, pretendo instalar o Hassio num raspberry pi que já se encontra com SO instalado (Raspbian), e seguindo o tutorial oficial de instalação: https://www.home-assistant.io/hassio/installation/ após ter todas as dependências instaladas, ao correr o comando final para a instalação do hassio propriamente dito, obtenho o seguinte erro: [ERROR] Please set machine for armv6l
Após alguma investigação, verifiquei que ao correr o comando “arch” ele retoma com a informação do estado em que o sistema já se encontra, e neste caso ele diz já estar em armv6l.
Alguém por acaso tem ideia do que possa estar a originar este erro?
Obrigado desde já.


(Jorge Assunção) #2

Se já tens o Raspbian instalado podes utilizar outro tipo de instalação. O Hassio é um “pack” que engloba o Home Assistant e o SO (HassOS) e que deve ser gravado directamente num SD.


(Nuno Neves) #3

@j_assuncao, o hass.io é docker, portanto pode ser instalado em raspbian… Outra coisa é a imagem que inclui o hassos e o hass.io


(Jorge Assunção) #4

Sim, eu sei mas o tutorial referido pelo @Lazaro_enes é o da instalação do Hassio num cartão SD e não o da instalação da imagem do Hassio em Docker…

Dai eu pensar que deve haver alguma confusão por parte do Lazaro ou enganou-se no link do tutorial :grinning:. O tutorial para a instalação do Hasio em Docker é este:


(Nuno Neves) #5

Não… Esse é o tutorial para instalação do home assistant em docker… Eu referia-me mesmo ao hass.io,com add-ons e tudo, que pode ser instalado em raspbian ou noutro OS…
https://www.home-assistant.io/hassio/installation/#alternative-install-on-generic-linux-server


(Lazaro Enes) #6

Boas pessoal,
obrigado pelas respostas, o que era pretendido era instalar o hassio (com add-ons e isso tudo) num servidor linux genérico, e não o home assistant (versão limpa) ou hassio por imagem de SD. O link que inseri no tópico, no fim da página encontra-se o que realmente tentei fazer, a instalação alternativa, que neste caso é o link inserido aqui por ultimo pelo @Maddoctor. É ao fazer esse procedimento que obtenho o erro mencionado no tópico, não sei se isso poderá ter solução, e informo também que estou a tentar fazer isto num raspberry pi zero, este que durante algum tempo teve hassio a funcionar por imagem de SD, mas como esse é um OS diferente acaba por não funcionar com outros serviços que pretendia instalar no pi zero.
Mais uma vez obrigado :slight_smile:


(Jorge Assunção) #7

Depende dos serviços. Se tiveres um Addon para o Hassio e preferível não mudar.

Mas um ou zero para isso parece-me muito curto. Tens várias lojas em portugal a vender o rpi3B+ por bom preço.