Falha de comunicação com os Sonoff

Boas, tenho o Home Assistant a correr numa raspbery pi 3 estava a fazer testes e reparei que quando desligo a alimentação e volto a ligar quando arranca fica sem comunicar com os sonoff o mesmo acontece se desligar o cabo de rede e voltar a ligar tenho que reiniciar os sonoff para começar a comunicar, estou em dizer que já fiz este teste e continuava a comunicar.

Tenho os sonoff com o tasmota a comunicar por mqtt
Já vos aconteceu o mesmo?

Mudaste alguma coisa na configuração do tasmota de origem se sim o que?

E qual a configuracao que usas no Ha?

Tinha um sonoff single a funcionar a cerca de 3 semanas, esta semana adicionei 5 sonoff dual. Ja coloquei a configuração de origem excepto o mqtt para comunicar.
No HA tenho tenho os sonoff, uma tv e uma box da vodafone.
Já desinstalei o mosquitto e voltei a instalar ao configurar o user e a pass os sonoff ligaram logo de imediato só que de seguida basta desligar o cabo de rede da rasberry que deixam de comunicar.

Mas deixam de comunicar com o rpi ou com a rede? Se continuam ligados à rede, tens de saber qual é o IP deles e aceder-lhes por web. Depois vai à consola e vê se há alguma referência à perda de comunicação com o servidor mqtt… Se for esse o caso, é o mosquitto que está a dar os problemas…

Já está resolvido, na segunda tentei alterar o ip do HA para ip fixo mas não consegui fica sempre com o ip automático de momento está sempre a atribuir o mesmo e também confirmei isso, como é um ficheiro que está no cartão de memoria e como não detectei este problema na altura deixei estar e não me lembrei mais.
Na consola do sonoff estava sempre a tentar comunicar bastava reiniciar o mesmo e ficava logo a funcionar correctamente.
Nada como dormir sobre o assunto…:joy:
Obrigado pela ajuda!

Quanto ao IP fixo, o meu conselho é que atribuas IPs fixos a todos os aparelhos, mas no próprio router… Para isso o ideal é ter um router “próprio” e não do operador, apesar de também dar para fazer isso no dos operadores…

Os sonoff já estão todos com ip fixo, no HA é que ainda não consegui, reservei o ip no router mas por duas vezes que ao reiniciar atribuiu outro ip.

Não sei qual o SO que estás a utilizar mas isto resolve o teu problema para teres IP fixo.

Para Hassio:

https://docs.resin.io/reference/resinOS/network/2.x/#setting-a-static-ip

Para outros:

https://www.modmypi.com/blog/how-to-give-your-raspberry-pi-a-static-ip-address-update

Tenho uma rpi com o Hassio segui as regras do 1º link e não consegui.
Vou voltar a tentar, pode ser que tenha feito algo de errado.

Isso tem de ser feito com o Rpi desligado, tiras o cartão, editas o ficheiro, confirmas se está tudo bem e o nome.do ficheiro está correcto, voltas a colocar o cartão e ligas de novo o Rpi.

Se fizeste alterações no router apagas essas alterações e certifica-te que não estás a dar um endereço IP já existente noutro equipamento.

Sim foi isso que fiz, o nome do ficheiro mantive o mesmo.
Estou a tentar outra vez.

Como te estás a ligar, cabo de rede ou WiFi? Pública o ficheiro de configuração para eu ver.

Já esta resolvido fiz tudo igual, reiniciei o router, não me lembro se o fiz da ultima vez, mas de qualquer forma devia de iniciar com o ip programado no HA.
Obrigado

1 Like

Boas, quando desligo e volto a ligar o cabo de rede ou quando á uma falha de energia os sonoff dual ou reiniciar o serviço mqtt mosquito dão uns impulsos ao arrancar.
É normal acontecer isto, é que estou a pensar colocar a funcionar nas persianas e estou com receio nos dias em que falha a luz ou uma falha de comunicação comecem a abrir.

No tasmota tens o powerretain definido?

Sim tenho, so me acontece isso nos sonoff dual no single funciona normal.
Ontem tive que voltar a instalar o mqtt, porque cada vez que retirava alimentação dos sonoff o relé que eu tenho neste caso defenido para fechar ficava ativo, o mesmo acontece quando desligo o cabo de rede da rpi e volto a ligar.
O ultimo teste que fiz ao fazer o restart do mqtt ficaram todos ativos.

Provavelmente para os sonoff dos estores é melhor escreveres na consola
powerretain1 0
powerretain2 0
poweronstate 0
Deve funcionar… :slight_smile:
(o retain flag para os estores - em que o motor se desliga sozinho - em princípio só prejudica…)

Já tinha experimentado mas voltei a testar, continua igual.
Tenho esta configuração para um switch penso estar correta:

switch 1:

  • platform: mqtt
    name: “Abrir Persiana”
    state_topic: “stat/sonoff51/POWER1”
    command_topic: “cmnd/sonoff51/power1”
    payload_on: “ON”
    payload_off: “OFF”
    qos: 0
    retain: true
    optimistic: false
  • platform: mqtt
    name: “Fechar Persiana”
    state_topic: “stat/sonoff51/POWER2”
    command_topic: “cmnd/sonoff51/power2”
    qos: 0
    retain: true
    optimistic: falseTexto pré-formatado

Em princípio, o ideal era usar um cover em vez de um switch:

cover:
  - platform: mqtt
    state_topic: "stat/sonoff51/POWER1"
    command_topic: "cmnd/sonoff51/Backlog"
    name: "Persiana"
    qos: 0
    retain: true
    payload_open: "power1 ON"
    payload_close: "power2 ON"
    payload_stop: "power1 OFF;power2 OFF"
    state_open: "ON"
    state_closed: "OFF"
    optimistic: false
    value_template: >-
      {% if value_json.POWER1 == 'OFF' and value_json.POWER2 == 'OFF' %} 50 
      {% elif value_json.POWER1 == 'OFF' %} 100 
      {% elif value_json.POWER2 == 'ON' %} 0 
      {% endif %}

Tenta assim…

@hmplima, quando publicares código, selecciona o texto e depois clica na opção </>