Hassio+RPI3 bloqueia se o router reiniciar


(Francisco Silva) #1

Tal como o título diz se o router reiniciar o raspberry com o home assistante bloqueia…
Deixo de conseguir por todos os meios aceder após estar tudo ok com o router.
Para já estou a testar apenas com um sonoff com tasmota.
O sonoff também já não consegue comunicar com o hassio depois do reboot.

No router o rpi3 fica inactivo…

O rpi3 está com ip fixo…ligado por cabo…
Estou a usar a última versão do HA, a 0.75.0.
Um RPI3 model B.

Só volta a funcionar desligando o rpi na fonte…

Alguma ideia do que possa ser?

Desde já obrigado


(Jorge Assunção) #2

Isso é um problema típico de endereços IP atribuídos por DHCP…

O Sonoff também tem o IP fixo?

Como estás a atribuir o IP fixo, no router ou nos equipamentos?

O Rpi liga-se por cabo mas tem as configurações para se ligar por wifi?


(Francisco Silva) #3

O router está a atribuí-los automaticamente. E sim, pelo que vi está a ser por DHCP… e estão como fixos…

Já vi que se quiser posso ser eu a atribuir o ip aos sonoff mas tem de ser através do arduino ide ao flashar com tasmota, certo?
EDIT: já vi que dá para enviar comando através da consola para alterar o ip…

No RPi não usei configurações para ligar por wifi. Foi só sacar o file do hassio e instalar…

Já agora o router é um Thomson TG784 da meo…


(Jorge Assunção) #4

Podes mostrar a página do router com a configuração dos IPs?

A interface web do Tasmota também dá para atribuir o IP sem teres de usar a consola, embora pela consola seja mais flexível.

Já agora, o Hassio que tens qual é a versão e qual é o SO de base, ResinOS ou HassOS?


(Francisco Silva) #5

neste momento já meti os ips dos sonoff como fixos nos próprios equipamentos…

Estava a usar o HassOS…

Neste momento não consigo é fazer mais nada pois como andava a inventar a tentar solucionar o problema deu-me para começar do zero com a instalação.
Neste momento no Hassio 0.75.1 tem um bug que no home dá “404 not found”.

Devido a isso não consigo fazer mais nada pois não encontrei solução para isso enquanto não sair nova actualização…

Antes estava atribuido sempre o mesmo ip por DHCP…


(Jorge Assunção) #6

Podes sempre fazer o downgrade para uma versão anterior…


(Francisco Silva) #7

como sou ainda um bocado novo nestas andanças, como é que faço isso?
é que o cartão tem uma instalação limpa…


(Jorge Assunção) #8

Acedes por SSH ao Rpi (podes ter de instalar o addon) e usas o seguinte comando:

hassio homeassistant update --options “version=0.75.0”

Podes andar mais versões para trás, se necessário, mas deves usar apenas versões que tenham o HassOS como base.


(Francisco Silva) #9

pois, o problema está aí, como instalar o addon se não tenho acesso ao menu?


(Jorge Assunção) #10

Não consegues aceder ao endereço IP interno?

EDIT: Podes configurar o IP do Rpi, entre outras coisas, com estas instruções:

https://github.com/home-assistant/hassos/blob/rel-1/Documentation/configuration.md#automatic

https://github.com/home-assistant/hassos/blob/rel-1/Documentation/network.md


(Francisco Silva) #11

já me consegui ligar com o putty mas não está a fazer a conecção ao meter o comando:


(Jorge Assunção) #12

Tenta utilizar este comando:

ping 192.168.1.1

Troca o IP pelo endereço do teu router. Utiliza CTRL+C para sair do comando.

Qual é a resposta a esse comando?


(Joel) #13

Boas,

como indiquei noutra thread e ajudando aqui o colega :), com o novo hassOS a prompt disponivel é sempre alterada de forma que só seja possivel usar comandos HA.

"
hassio > ping 192.168.1.254
hassio: ‘ping’ is not a hassio command. See ‘hassio --help’.
"


(Jorge Assunção) #14

Eu tenho acesso ao ping pela porta 22…

Capturea

E também pela 22222, embora com um conjunto de comandos diferentes…

Captureb

Talvez seja bom ler sempre os textos que aparecem depois de fazer login, pois contem informações úteis:

If you need access to host system use ‘login’.


(Francisco Silva) #15

em relação ao acesso com o novo update já não há problema em aceder ao painel…
No entanto mesmo com uma instalação limpa se reiniciar o router, o rpi/home assistant ficam inactivos após o reboot…


(Jorge Assunção) #16

E quanto tempo estás a esperar até dizeres que ficam inativos?


(Joel) #17

Boas,

tens toda a razão :slight_smile:
Efectivamente costumo ignorar o MOTD :slight_smile:
Obrigado!


(Francisco Silva) #18

Eu só reparei que ficava inactivo quando comecei a verificar o modo de atribuição dos ips. e se os mesmos por acaso alteravam.
Só tive mais tempo para ver isto melhor ontem ao fim do dia…

CONFIGURATION.YAML

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 0
  longitude: 0
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: UTC
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
#introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

sensor:
  - platform: time_date
    display_options:
      - 'time'
      - 'date' 

http:
  # Secrets are defined in the file secrets.yaml
  # api_password: !secret http_password
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Weather prediction
sensor:
  - platform: yr

# Text to speech
tts:
  - platform: google

# Cloud
cloud:

weather:
  - platform: ipma   

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

Apenas adicionei o tempo do ipma…
Não tem mais nada alterado…

  • Home Assistant 0.75.2.
  • HassOS 1.9

Addons - Samba

Router: Thomson TG784

O ip do rpi nunca alterou…

Testei agora novamente e a atribuição mudou de DHCP para estático:


(Francisco Silva) #19

Entretanto e depois de vários testes descobri o problema…
Desliguei o IPV6 no router e agora já funciona normalmente…

Fartei-me de pesquisar e não encontrei ninguém com este problema.
Serei o único com este router adsl da Meo que tive este problema?