MadBlinds v1 - Como ligar estores eléctricos a um Sonoff Dual (descontinuado)


(Rodolfo) #1

Atenção!
.
Este tutorial encontra-se descontinuado. Podes encontrar a nova versão em deste tutorial em:
📑 MadBlinds v2 - Como Controlares os estores eléctricos e "estimares" a sua posição


:bookmark_tabs: MadBlinds v1 - Como ligar estores eléctricos a um Sonoff Dual (descontinuado)
(Ricardo Santos) #2

Desde já obrigado pelo tutorial e código.
Istalei no Sonoff dual R2 e na parte fisica do interruptor funcionou impecável ao contrário da anterior versão que eu tinha do tasmota, esta dava erros e desligava a parte ascendente e descendente ao mesmo tempo.
Não consigo é fazer o resto, não aparece ligação wifi para me ligar e configurar…


:bookmark_tabs: MadBlinds v1 - Como ligar estores eléctricos a um Sonoff Dual (descontinuado)
(Rodolfo) #3

@Ricardo_Santos e já verificaste no teu router se nao tens já o ip atribuido? Ele só entra na rede wifi para tu definires um ip, senão ele atribui o ip automatico. Ve no teu router.


(Ricardo Santos) #4

Não pode entrar no meu router pois nao acede ao wifi, nao introduzi nenhuma pass


(Luís Martins) #5

Viva. Tenho uma configuração idêntica a funcionar em 3 estores, mas com firmware espurna.

Recentemente dois dos estores (os maiores) começaram a funcionar mais lentamente e com um barulho que dá a sensação que o motor está a trabalhar mais devagar/em esforço. Poderá ter alguma coisa a ver com o relé?


(Jorge Assunção) #6

Penso que não. Poderá talvez ter a ver com um problema nos motores ou alguma ripa do estore estar presa.

Experimenta, se possível, trocar um dos Sonoff que está a dar problemas pelo que está a funcionar bem.


(Paulo) #7

Eu para instalar nos meus que tipo de motor tenho que comprar, não sei que tipo de potência devem ter.
As minhas janelas de largura tem 2 metros e abrem/fecham por uma manivela o fio é de aço.


(Nuno) #8

Link de site para comprar a versão R2, alguém tem?


(Luís Martins) #9

Eu comprei os meus via Banggood


(Luís Martins) #10

Vou ver se no fim de semana abro novamente a caixa e verifico.

Achei um pouco estranho, porque o 1º que instalei continua a funcionar normalmente enquanto que estes dois últimos estão a ter o mesmo problema tendo ao problema manifestado-se com apenas alguns dias de diferença.

Obrigado


(Rodolfo) #11

@Ricardo_Santos Mas ja verificaste? Verifica porque podes ter usado um firmware anterior e ele ter já ip. Vai ao router e confirma.
E flashaste usando estas confs?

Se nao vais fazer o seguinte:
Usando essas settings vais descomentar no codigo por baixo do void setup estas duas linhas

//reset saved settings
//wifiManager.resetSettings();

Ou seja apagas os // depois verifica se o sonoff ja te aparece nas redes wifi…se aparecer voltas a flashar e metes os // outra vez. Ok?


(Ricardo Santos) #12

Vou ver isso logo a noite, obrigado pela atenção.


(Ricardo Santos) #13

exit status 1
’reset’ was not declared in this scope

deu este erro ao fazer isso


(Rodolfo) #14

@Ricardo_Santos Se calher enganei-me deixa tira so as // do //wifiManager.resetSettings(); e deixa as outras no reset saved settings

ou seja fica assim:

//reset saved settings
wifiManager.resetSettings();

(Ricardo Santos) #15

Acho que já resultou, mas agora fiz ligar à minha rede e não acontece nada. o que devo procurar?

edit

já funciona no HA…

Mas não como eu queria…
se carregar na tecla para subir estore , se depois carregar no HA para descer , nada acontece, deveria anular o subir da tecla e descer…

e não tem timeout

temos de arranjar um compromisso entre este codigo e o tasmota. O tasmota funciona bem no HA e mal nas teclas. Este é ao contrario…


(Rodolfo) #16

Mas so pelo Ha funciona bem? Eu fiz um teste mas foi com interruptores de pressao.


(Jorge Assunção) #17

Experimenta o Espurna @Ricardo_Santos


(Rodolfo) #18

@Ricardo_Santos ainda assim estou a achar isso estranho…porque quando carregas no interruptor fisicamente ele esta no estado ON mas o que acontece se voltares a por o interruptor como estava?


(Ricardo Santos) #19

Nos botões do interruptor tudo funciona bem. Liga switch1 , liga switch 2 e desliga switch1, liga switch 1 e desliga switch 2, depois se desligar o switch 1 ele desliga. No Ha só funciona se nos botões fisicos estiverem em off. O que acontece na vida quotidiana é que quando eu carrego no botão para descer os estores eles vão descer e eu não fico à espera que acabe, vou fazer outra coisa. Eu quero poder automaticamente depois subir pelo HA ficando o botão para baixo no interruptor. Isto no Tasmota funciona.


(Ricardo Silva) #20

Foi o que falei nesse topico: Como Ligar um Bh onofre a uns estores eléctricos

Só que não sei se podes meter esse codigo no sonoff. Caso podes é só alterar o pinout para ser o do sonoff.

Não testei ainda porque não tenho ainda o material, estou a aguardar ainda.