MadBlinds v2 - Como Controlares os estores eléctricos e "estimares" a sua posição


(Jorge Assunção) #41

O problema poderá estar, quase de certeza, no facto de teres algumas entradas (sensor, binary_sensor, homeassistant, camera) que estão vazios.

Se as entradas não têm nada devem estar comentadas.


(André F. Cruz) #42

Já resolvi o problema.
Como o painel das minhas automações estavam ocultas, não conseguia ver que o slider estava desligado.


(Nuno Neves) #43

Ainda bem! Era mesmo isso que te dizia acima… :wink:


(André F. Cruz) #44

Ainda estou a iniciar-me nestas andanças e mais de metade do que leio é chines para mim e não percebo o que devo de fazer.

Mas finalmente está a trabalhar.
Vamos agora ao proximo desafio. :smile:


(Rodolfo) #45

Boa André , mas não entendi bem.
Conseguinte a por a funcionar no modo package? Seria bom que sim, para aquele que te tinha dito.
Para ficar tudo mais organizado, para quando tiveres mais estores isso não ficar uma bagunça :slight_smile:


(André F. Cruz) #46

Está a trabalhar em modo package e muito bem.
Os estores os switchs e as automaçoes dos switchs.
Só falta as automações dos estores.


(Frederico Oliveira) #47

No meu parece estar tudo a funcionar ok, em modo packages.
Amanha posto um video do mesmo a funcionar porque viver so com hotspot não me permite grandes gastos de internet.
Mais uma vez parabens á comunidade pelos fantasticos desenvolvimentos.


(Jorge Assunção) #48

3 mensagens foram divididas em um novo tópico: Controlo de portão BFT


(Hugo) #50

Boas. Alguem já tentou passar a automação para o node-red?


(Rui Nunes) #51

Olá,

Desde a atualização do HA para a versão 0.80.0, os sliders dos meus estores, que funcionavam tão bem, deixaram de funcionar. Alguém me sabe dizer porquê?

Desde já, o meu agradecimento.


(Jorge Assunção) #52

E o que queres dizer com “deixaram de funcionar”? Não aparecem, não consegues utilizar…


(Rui Nunes) #53

Quando movo os sliders, os estores, simplesmente não respondem, mas se utilizar as setas para cima e para baixo, já funcionam.


(Nuno Neves) #54

Provavelmente as automações ficaram desactivadas… Só tens de activar e está…


(Rui Nunes) #55

Nunca ouvi falar em automações desativadas, podes dizer-me como as ativar?

Obrigado.


(Rui Nunes) #56

Já recarreguei as automações e ficou a dar.
Obrigado pela ajuda :slight_smile:


(Nuno Neves) #57

Depende de como tiveres o teu UI.

Mas em princípio colocas no ficheiro customize.yaml

group.all_automations:
  hidden: false

Depois pões no UI o group.all_automations…


(Rodolfo) #58

Uma mensagem foi dividida em um novo tópico: Controlar estores electricos por IR e saber a sua posiçãoo


(Nelson Oliveira) #59

Uma pequena dúvida:

nesta automação: (como na “abrepeloslider”)

 - id: fechopeloslider
      alias: Fecho pelo slider
      trigger:
        platform: state
        entity_id: input_number.aberturapersiana
      condition:
      - condition: template
        value_template: '{{ states.input_number.aberturapersiana.state|int < states.input_number.aberturapersianaold.state|int }}'
      action:
      - service: input_boolean.turn_off
        data:
          entity_id: input_boolean.alterarslider
      - service: mqtt.publish
        data:
          topic: 'cmnd/wemosd1mini/Backlog'
          payload_template: "POWER2 ON; delay {% if is_state('input_number.aberturapersiana', '0.0') %} {{ (((states.input_number.aberturapersianaold.state|int - states.input_number.aberturapersiana.state|int)*(states.input_text.tempodefecho.state|float)/100)|round(1)*10)|round(0) + 20 }} {% else %}
  {{ (((states.input_number.aberturapersianaold.state|int - states.input_number.aberturapersiana.state|int)*(states.input_text.tempodefecho.state|float)/100)|round(1)*10)|round(0) }} {% endif %}; POWER2 OFF"
      - delay:

A parte:
(states.input_text.tempodefecho.state|float)/100)|round(1)*10)|round(0) }}

é tambem para substituir o “*10” pelo tempo de abertura/fecho? Pergunto pois como coicide com o teu tempo de de 10s, poderá ter a ver… embora ache que não


(Rodolfo) #60

@Nelson_Oliveira deduzo que não, mas o @Maddoctor quando tiver disponibilidade já te informa.


(Nuno Neves) #61

@Nelson_Oliveira, não, os tempos de abertura e fecho só devem ser alterados onde diz no tutorial, ou seja, no input text que está no inicio