Problema a passar de 0.85.1 para 0.86.3


(Rui Oliveira) #1

Boa tarde, estou a tentar a passar da versão Hassio 0.85.1 para a versão 0.86.3, apesar de alterar o time para xxxx, quando faço validar a configuração estou cheio de erros tais como:

Invalid config for [automation]: [at] is an invalid option for [automation]. Check: automation->trigger->0->at. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.TV_Suite does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.TV_Suite does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: Service notify.Telegram does not match format <domain>.<name> for dictionary value @ data['action'][0]['service']. Got None. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/ Invalid config for [automation]: [at] is an invalid option for [automation]. Check: automation->trigger->0->at. (See /config/configuration.yaml, line 180). Please check the docs at https://home-assistant.io/components/automation/

Perco logo a vontade, e lá vou eu para a versão 0.85.1, mais alguém tem este tipo de problemas?

vou a linha 180 e não estou a ver qual o problema/ solução.
Isto é o que tenho da linha 175 a linha 188:

# Acesso aos ficheiros de configuração
light: !include light.yaml
switch: !include switch.yaml
sensor: !include sensors.yaml
camera: !include cameras.yaml
binary_sensor: !include binary_sensor.yaml
automation: !include automations.yaml
script: !include scripts.yaml
group: !include groups.yaml
media_player: !include media_player.yaml
history_graph: !include history_graphs.yaml
zone: !include zones.yaml
#notify: !include notify.yaml
#device_tracker: !include device_tracker.yaml

Se alguém já passou pelo mesmo problema e tiver solução agradeço.

cumprimentos,


(Ricardo Silva) #2

Ola Draco,

A linha 180 corresponde ao teu ficheiro automation.yaml como esta indicado logo ao inicio do erro:

Tens que ter em atenção, que na versão 0.86.x houve alterações com o time que passa a time_pattern só em certas ocasiões:

Depois a outro problema que tive que não podes meter o “from”, exemplo:

- alias: Desligar Monitores
  trigger:
    platform: state
    entity_id: switch.my_pc
    # from: 'on'
    to: 'off' 

Espero que te ajuda.


(Rui Oliveira) #3

Obrigado, vou ver se consigo resolver dessa maneira, o time já tinha resolvido. Não sabia a do “from”.


(Ricardo Domingos) #4

Olá o problema é que com a atualização notify.Telegram deve estar em minusculo. notify.telegram


(Rui Oliveira) #5

Obrigado @Ricardo_Domingos, já verifiquei que tinha alguns como Telegram.
Alteração efectuada, agora só me falta coragem para fazer o update:smile:
Cumprimentos


(Rui Oliveira) #6

Boa noite, obrigado pelas dicas dadas, já estou com a última versão.
Os erros eram mesmo esses, isto é, Letra maiúscula no telegram e o from.
Resolvido, versão actual 0.86.4 agora vou começar a migrar para lovelace.

Cumprimentos,