Sonoff Basic com Tasmota - erro a ligar ao HA MQTT


(Bruno Santos) #1

Olá a todos.
Já tenho o HA configurado, com o Mosquitto MQTT addon configurado e a correr.

Do meu computador, usando o mosquito_pub, consigo ligar ao mosquitto e tudo funciona como deve ser, aparecendo nos logs a ligação.

1560035632: New client connected from 192.168.2.10 as mosqpub|20702-nightcraw (c1, k60, u'mosquitto').
1560035632: Client mosqpub|20702-nightcraw disconnected.

Seguindo as instruções no forum, flashei um sonoff basic com tasmota… Tudo sem problemas, mas não consigo que se ligue por MQTT ao HA.
Na consola do sonoff, dá sempre erro …

Não sei o que fazer…

sonoff_console

Supostamente, já não é necessário configuração no configuration.yaml, mas com configuração, sem configuração é sempre o mesmo…

Alguma ajuda era optima ! Obrigado


(Nuno Neves) #2

Em princípio será um problema com o ip do broker ou com a autenticação…
No log do mosquitto aparece alguma referência À tentativa de ligação do tasmota?


(Bruno Santos) #3

Bom dia!

Não aparece nada nos logs…
Mas erro do ip não é, pois do meu computador pessoal consigo ligar e aparece nos logs do mosquitto no HA…

Não consigo perceber… Há mais algum local onde possa ver logs? Algum comando no sonoff que possa executar e ver as comunicações dele com o broker?


(Rodolfo) #4

Já experimentaste usar outro username e outra password?
Não tenho a certeza mas deduzo que não podes usar esse username.


(Jorge Assunção) #5

O username mosquitto já foi uma palavra reservada mas não sei se ainda é. E atenção que o Client tem de ser um nome único na rede.

Qual é o IP do teu HA?


(Bruno Santos) #6

Eu li e só não podia ser homeassistant e outra qualquer. Mas eu posso mudar. A questão é que do meu PC pessoal chego lá, mas não do sonoff.

o IP é 192.168.2.31… o do sonoff é o 192.168.2.49 …


(Luís Miguel Andrade) #7

Desabilita a autenticação e tenta verificar se é possível obter conectividade.


(Bruno Santos) #8

Igual !

Consigo do meu PC, mas nada do sonoff basic.

Eu estou a usar o RaspAssio (deste tutorial: De Hassio para 'RaspAssio') .

Amanhã testo a bridge… A ver se acontece o mesmo


(Bruno Santos) #9

Resolvido.

Tive que ligar o Home Assistant por cabo em vez de wifi… Desconfio que alguma configuração no RaspAssio, do docker ou do apparmor que não permite ligações via wifi…

Obrigado a todos !


(Jorge Assunção) #10

Se consegues por cabo e não por WiFi o problema poderá estar no router…


(Bruno Santos) #11

Tenho que analisar melhor, mas não penso que seja isso… Mas não importa. Já está, já está.
Agora é colocar (para testar) este sonoff que está ligado a um candeeiro acender a lampada assim que o PIR2 detetar movimento…

A ver se consigo ! :smile:


(Jorge Assunção) #12

Sim, é verdade. Mas o HA não deve nunca ser ligado por WiFi à rede e sim por cabo por motivos de fiabilidade.


(Bruno Santos) #13

Já descobri porque é que - por wifi - o sonoff não comunicava MQTT com o HA.
Eu tenho rede wifi (e cablada) toda da ubiquity. No software da Ubiquity é necessário permitir multicast e broadcast nos sonoff. Permitindo, já funcionam bem ! :slight_smile:

Deixo aqui porque alguém pode precisar.