Sonoff estore king Q4


(Rato23) #1

Tenho esse dispositivo e que já percebi como fazer as ligações para o flashar no entanto ele tem led’s azuis e vermelhos, eu tentei googlar e tentar perceber como poderei controlar as luzes individualmente, basicamente a questão era codigo para durante o dia estarem desligadas e ligarem só a noite (a automatização é simples, o codigo para controlar os led’s já nao consigo “pescar”).


(Jorge Assunção) #2

Se tivéssemos um pouco mais de informação talvez fosse possível ajudar-te, como por exemplo que firmware vais pôr (ou já puseste)…


(Rato23) #3

Esqueci-me xD, estava a pensar colocar tasmota, penso que é o melhor não?


(Jorge Assunção) #4

Sim, o Tasmota é a melhor opção.

  1. Qual é a potencia dos reles desse interruptor?
  2. Quais são os LEDs que queres controlar?

(Rato23) #5

Em torno a cada touch tem um led azul e outro vermelho que penso serem controlados individualmente e não os 3 em simultaneo, já vi alguns projetos mas pelo que consigo perceber e como sou nabo, logo quando se flasha tem que se colocar no codico forma de os controlar.

Encontrei (https://community.home-assistant.io/t/flashing-latest-sonoff-t1-tasmota/107943/3) algo parecido mas não sei se é bem para o meu caso.


(Jorge Assunção) #6

No Tasmota não tens de compilar nada de inicio. Todas as configs podem ser alteradas depois de estar flashado.

Começa por flashar o Tasmota nisso e depois vamos ver essas configurações.


(Rato23) #7

Eu tenho tomadas também da sonoff e queria fazer o mesmo, em princípio os comandos devem ser os mesmos, só devo ter tempo para flashar no fim de semana, podemos ir testando nas tomadas s20?


(Jorge Assunção) #8

Podes testar com o seguinte:

Basicamente crias uma automação em que da hora x1 à x2 está aceso e das hora y1 à y2 está apagado


(Rato23) #9

Funciona com o “LedPower” mas só um dos led’s o outro deve ser o relê mas n o consigo ativar.


(Rato23) #10

Flashei com o ESPHOME que me parece porreiro e funcional, no entanto algo está errado, os botões fisicos funcionam mas no HA os botões da cover não funcionam e só consigo que um LED do wifi ligue e desligue… deixo aqui o codigo mas as minhas capacidades não dão para mais… se alguem poder ajudar, agradeço :slight_smile:

esphome:
  name: estore_quarto
  platform: ESP8266
  board: esp01_1m

wifi:
  ssid: "xxxx"
  password: "xxxx"
  
  manual_ip:
    # Set this to the IP of the ESP
    static_ip: 192.168.1.82
    # Set this to the IP address of the router. Often ends with .1
    gateway: 192.168.1.254
    # The subnet of the network. 255.255.255.0 works for most home networks.
    subnet: 255.255.255.0  

# Enable logging
logger:

# Enable Home Assistant API
api:

ota:

binary_sensor:
  - platform: gpio
    pin:
      number: GPIO9
      mode: INPUT_PULLUP
      inverted: True
    name: "Abrir"
  - platform: gpio
    pin:
      number: GPIO5
      mode: INPUT_PULLUP
      inverted: True
    name: "Stop"
  - platform: gpio
    pin:
      number: GPIO4
      mode: INPUT_PULLUP
      inverted: True
    name: "Fechar"
  - platform: status
    name: "Estado"



switch:
- platform: gpio
  name: "Open"
  pin: GPIO9
  interlock: &interlock [open_cover, close_cover]
  id: open_cover
- platform: gpio
  name: "stop"
  pin: GPIO5
  interlock: *interlock
  id: stop_cover
- platform: gpio
  name: "Close"
  pin: GPIO4
  interlock: *interlock
  id: close_cover  

cover:
- platform: time_based
  name: "Cover"
  id: my_cover
  open_action:
    - switch.turn_on: open_cover
  open_duration: 70s
  close_action:
    - switch.turn_on: close_cover
  close_duration: 70s
  stop_action:
    - switch.turn_off: open_cover
    - switch.turn_off: close_cover  

output:
  - platform: esp8266_pwm
    id: blue_led
    pin: GPIO13
    inverted: True

light:
  - platform: monochromatic
    name: "Led estore"
    output: blue_led