Sonoff SV para controlar portão

Boas, atualizei o sonoff sv com tasmota para versao 6.3. Estava na 5.14. acontece que tive um problema a atualizar via OTA e tive que flashar de novo e perdeu as configs. Nao estou a conseguir configurar o state. O sonoff sv tem um reed switch para informar o estado do portao. Mas agora apenas estou a conseguir abrir/fechar o portao mas o estado está sempre fechado. Alguem que possa me ajudar a configurar isto?

Obrigado

Configuraste o sensor?

Como é que tens as configurações do lado do tasmota e do ha?

Eu não percebo muito da configuração… Agora nao estou em casa nao sei dizer ao certo. O que ta configurado foi atraves de um video, mas sempre tive probelmas até que o @RodolfoVieira me ajudou, com algumas horas de volta daquilo… Mas nunca percebi como configurar… Tanto na parte do HA, como do tasmota :neutral_face:

Se bem me lembro o tutorial onde isso estava era aqui:

Tenta ver novamente e testar, depois caso não consigas, coloca aqui todo o código, para nós vermos se conseguimos ajudar.
Sem código nada feito.

No tasmota tens um opção que faz backup da configuração, naõ fizeste isso na altura?

No entanto para um sensor reed, tens que configurar um switch e um relay, sabendo que esse relay não o vais usar, mas fica associado ao switch, que na realidade é o reed,

Exemplo, um tasmota com 2 lampadas + 1 sensor reed


https://gyazo.com/707ee30a2f007132db30c7e0ba4c1f58

@ricain não deve ter feito…

O teu problema será, provavelmente, não teres configurado um rele “virtual” associado ao reed…
Coloca um print da configuração que tens no “module configuration” (não coloques as imagens directamente - coloca por link externo…)

Eu agora nao tou em casa. Amanha meto as configs. Mas nao tenho isso…

Ok. Eu agora nao tou em casa. Amanha meto aqui as configs para me ajudarem

Afinal ainda consegui meter hoje as configs:

Config HA: https://ibb.co/fpk8zq
Config Tasm0ta: https://ibb.co/gDrRkV

Na console do Tasmota fiz o seguinte:
poweronstate 0
switchmode1 2
switchmode2 0
powerretain 0
switchtopic 0
switchretain 1

@RodolfoVieira @Maddoctor @ricain @tmarquespt

Falta atribuir gpio ao Reed… A que gpio é que ele está ligado?

Penso que seja isto… O que tenho de fazer?

Consegues pôr aí uma foto das ligações no teu aparelho?

Está aqui o esquema de como eu tenho:

Foto mesmo não consigo tirar. Tenho que desmontar e dá algum trabalho. Só em caso de necessidade, mas penso que o esquema serve. O que devo fazer @Maddoctor ?

Em princípio tens de configurar o gpio14 para switch 2 e um dos outros gpio para relay2. Depois no HA trocas o state topic para stat/portaodefora/POWER2

assim deve funcionar…

Já dá… Obrigado! Porque é que a configuração é feita dessa maneira? Podes explicar para tentar perceber?

O tasmota não reporta, habitualmente, o estado de um interruptor, apenas de um relé. Ele parte do princípio que o interruptor 1 controla o relé 1 e por aí adiante. O que fizeste foi colocar o Reed como se fosse um interruptor. Depois, para que reportasse o estado tiveste de criar um relé “virtual” associado a esse interruptor… Nao podia ser switch1 porque esse controlar ia o relé físico do sonoff…

Um aparte - devias ter powerretain 1 e switchretain 0

2 Likes

Ok. Vou alterar isso. Obrigado pela ajuda @Maddoctor

Este tópico foi automaticamente fechado 90 dias após a última resposta. Novas respostas não são permitidas.