Switch MQTT com BH onofre

mqtt

(Luís Martins) #1

Viva.

Não consigo integrar o Onofre no HA, nem com autodiscovery nem adicionando manualmente. O MQTT está corretamente configurado visto que consigo interagir via MQTTFX e mesmo publicando a mensagem via Homeasssistant. Quando configuro manualmente o switch, este não funciona nem relata corretamente o estado. Com autoDiscovery a entidade nem sequer é detectada.

Estou a usar o firmware EasyIot 4.9.

Nota: flashei e testei com espurna e funcionou corretamente pelo que o problema deve ser a nível de firmware.

Alguma sugestão de configuração?

Obrigado


(Nuno Neves) #2

Usa tasmota. Está muito bem documentado…


(Luís Martins) #3

Ainda não consegui compilar corretamente o Tasmota (tenho de eliminar os (vários) erros que me aparecem. Para já só consegui flashar o Espurna (que funciona com MQTT, mas não tem a opção de funcionar com interruptor toogle) e o EasyIot (que funciona bem em quase tudo menos no switch da HA.


(Jorge Assunção) #4

@Luis_Martins o Tasmota não precisa ser compilado. Apenas em 0,1% dos casos há essa necessidade.

Tens no GitHub ficheiros bin já compilados para diversos dispositivos, basta procurar…


(Nuno Neves) #5

Não precisas de compilar nada… Usa uma versão precompilada que está disponível facilmente…


(Rodolfo) #6

@Luis_Martins podes fazer donwload da última release do tasmota :point_right: Aqui, e podes flashar a mesma no teu onofre seguindo este :point_right:Tutorial


(Luís Martins) #7

Obrigado a todos. Já aprendi mais alguma coisa. Pensava que o binário tinha que ser específico para o hardware (o espurna tem uma versão específica para o Onofre). assim que tiver oportunidade vou testar.


(Cesar Cristiano Soares Teixeira) #8

boas pessoal estou com um problema para conseguir por o meu esp8266 a trabalhar com o mqtt …
é o seguinte :

  • o esp8266 tem a o código do Bruno Horta do video do homeassistant mais o esp8266
  • estou a utilizar o mqtt como guest (sem pass)
  • o mqtt arranca sem erros (parece -me)
  • o mqtt.fx ele abre a ligação, mas não me deixa subscrever nenhum tópico(não sei porque)
  • no log do hassio no addon do mqtt, aparece sempre istas mensagem de detectou o esp mas depois desliga dele!

1557317641: New client connected from 192.168.1.104 as MAKERSWITCH (c1, k15). 1557317641: Socket error on client MAKERSWITCH, disconnecting. 1557317641: New connection from 192.168.1.104 on port 1883. 1557317662: New client connected from 192.168.1.104 as MAKERSWITCH (c1, k15). 1557317662: Socket error on client MAKERSWITCH, disconnecting. 1557317672: New client connected from 192.168.1.104 as MAKERSWITCH (c1, k15). 1557317672: Socket error on client MAKERSWITCH, disconnecting.

mqtt configuração:

{
  "logins": [],
  "anonymous": true,
  "quiet_logs": true,
  "customize": {
    "active": false,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

configuração do ficheiro do homeassistant :

homeassistant:
  # Name of the location where Home Assistant is running
  name: CASA
  # Location required to calculate the time the sun rises and sets
  latitude: 41.412696
  longitude: -8.198800
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 292
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Lisbon
  # Customization file
  customize: !include customize.yaml

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

http:
  base_url: 192.168.1.xx1:8123   
  api_password: "xxxxxxxxx"
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  ip_ban_enabled: True
  login_attempts_threshold: 3

mqtt:
  broker: 192.168.1.xx1 #127.0.0.1  Duvida aqui <------------------------------------------
  port: 1883
  client_id: homeassistant
  keepalive: 60
 # protocol: 3.1
# Discover some devices automatically
discovery:
##############################################
#####################telivisão###############
media_player:
  - platform: samsungtv
    host: 192.168.1.103
    port: 8001
    mac: b8:bb:af:2f:f5:90
    name: TV QUARTO
##############################################
##############################################
################TEMPO#########################
weather:
  - platform: ipma
    latitude: 41.412696
    longitude: -8.198800
###############################################
###############################################
# Sensors
sensor:
  # Weather prediction
  - platform: yr
###############################################
###############################################  
switch:
  - platform: mqtt
    name: "sala"
    state_topic: "casa/sala/luz/state"
    command_topic: "casa/sala/luz/set"
    payload_on: "ON"
    payload_off: "OFF"
    optimistic: false
    qos: 0
    retain: true
###############################################
###############################################

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

(Jorge Assunção) #9

Na configuração do MQTT o broker é o endereço IP da máquina onde está instalado o MQTT.


(Cesar Cristiano Soares Teixeira) #10

Sim tenho por exemplo
192.168.1.200 mqtt
Uma pergunta poderá ser o router a cortar??
É preciso abiri portas??
Acho estranho é ele ligar e depois desligar…do esp
E o mqtt.FX não subscrever tópico!!!


(Luís Martins) #11

O firmware do Bruno Horta assume que a porta do MQTT é a 1883. Um dos primeiros erros que fiz ao configurar o MQTT no firmware foi ter colocado o IP do broker com a porta do gênero 192.168.1.103:1883 o que causou problemas. Não sei se é isso que te está a acontecer…


(Cesar Cristiano Soares Teixeira) #12

o que me aconselhas amigo??? obrigado por a ajuda!!!
já agora porque diz que deve correr como root??? como posso correr como root???

[INFO] Setup mosquitto configuration
[INFO] Found local users inside config
[INFO] Initialize Hass.io Add-on services
[INFO] Initialize Home Assistant discovery
[INFO] Start Mosquitto daemon
1557343872: mosquitto version 1.5.6 starting
1557343872: Config loaded from /etc/mosquitto.conf.
1557343872: |-- *** auth-plug: startup
1557343872: Opening ipv4 listen socket on port 1883.
1557343872: Opening ipv6 listen socket on port 1883.
1557343872: Opening websockets listen socket on port 1884.
1557343872: Opening ipv4 listen socket on port 8883.
1557343872: Opening ipv6 listen socket on port 8883.
1557343872: Opening websockets listen socket on port 8884.
1557343872: Warning: Mosquitto should not be run as root/administrator.

(Jorge Assunção) #13

Pelo log (parece que) estás a utilizar o broker MQTT do sistema e esse vai ser descontinuado. Se sim instala o addon Mosquitto Broker.


(Cesar Cristiano Soares Teixeira) #14

esta a utilizar o mqqt do addon , tipo como instalar o samba!!
supostamente não e o embed!


(Cesar Cristiano Soares Teixeira) #15

Uma actualização o Mqtt.fx precisa de ter login
Para subscrever os tópicos… Agora ainda tou com
Problemas no esp8266, posso mudar a porta para
Outra?? Podem ajudar ?


(Jorge Assunção) #16

Qual porta? Se explicares qual é exactamente o problema pode ser que alguém possa ajudar…


(Cesar Cristiano Soares Teixeira) #17

O colega em cima disse que teve problemas
E era a porta 1883, que configurou outra!
A minha duvida é, se para configurar outra porta
pode ser uma qualquer a meu gosto (ex. Port:2020)
Ou tem portas alternativas para o mqtt, fixas??
Antes o mqqt.FX não subscrevia o tópico, mas já resolvi!
Foi meter um user e password no mqtt…
Sorry mas sou ainda muito verde nesta linguagens.


(Jorge Assunção) #18

Não foi isso que ele disse.

O que ele disse foi que por engano, ao configurar o firmware, tinha adicionado o :1883 no final do endereço mas que este já era adicionado e por isso tinha um erro. A solução foi tirar o :1883 da configuração.


(Cesar Cristiano Soares Teixeira) #19

Ok, pois tem razão, entendi que ele trocou a porta sorry!
Vim o meu logo do mqtt ele adeciona o ESP e depois
Desliga-mo , terá ideias o que pode causar isso ??


(Cesar Cristiano Soares Teixeira) #20

já consegui finalmente amigos!!!
instalei o tasmota direto do git e foi logo a 1º.
obrigado por a ajuda amigos