TTS no Google Home Mini


(Marco Pinheiro) #1

Boa tarde a todos,

Instalei recentemente um Google Home mini no meu setup. A configuração seguindo a documentação oficial decorreu sem problemas. No entanto, o TTS parece não funcionar. Já aconteceu com mais alguém? Se aceder ao componente media player, consigo ligar/desligar, alterar o volume, etc. Mas se envio uma frase para ele, não faz nada.

Muito obrigado!


(Jhonathan) #2

O meu também não faz nada… Acabei nem mexendo muito com o TTS


(Rodolfo) #3

@marcopinheiro como estás a enviar a frase?


(Marco Pinheiro) #4

Diretamente aqui para não haver espaço a grandes enganos em termos de código sequer:


(Rodolfo) #5

Estranho, não sei se houve algumas alterações com essa plataforma, eu uso tts mas uso a polly da amazon, e não em um googlemini. Ja testaste?


(Eduardo) #6

ta com ssl habilitado? pois com habilito o meu não funciona.


(João Ferreira) #7

Comentaste apenas estas linhas ou tiveste de fazer mais alguma coisa?

http:
  base_url: !secret http_ip   
  api_password: !secret http_pass
  # ssl_certificate: /ssl/fullchain.pem
  # ssl_key: /ssl/privkey.pem
  ip_ban_enabled: True
  login_attempts_threshold: 3

(karma) #8

@marcopinheiro, Que configuração tens para conseguires ligar/desligar, alterar volume do Google Home mini?
Tens como mediaroom?
Obrigado


(Marco Pinheiro) #9

Não tenho nada disso, e nunca cheguei a conseguir configurar o TTS :frowning:


(karma) #10

Pensei que tivesses…
Estava aqui a experimentar e de facto é como o @unchuck estava a dizer. Com o ssl habilitado não da para controlar nem enviar tts. Se o remover aí sim.


(Jorge Assunção) #11

@marcopinheiro
Eu tenho a seguinte configuração:

#### GOOGLE CAST
cast:
  media_player:
    - host: 192.168.1.19
#### GOOGLE ASSISTANT
google_assistant:
  project_id: !secret google_assistant_project_id
  api_key: !secret google_assistant_api_key
  exposed_domains:
    - switch
    - light
    - script
    - media_player
#### TTS    
tts:
  - platform: voicerss
    api_key: !secret tts_voicerss_api_key
    language: 'pt-pt'
    codec: mp3
    format: '16khz_16bit_mono'

(karma) #12

@j_assuncao obrigado mais uma vez :+1:
Já consegui resolver este problema do tts ( pelo menos para mim funcionou).
Tive que alterar o “base_url” do “http:” para o “endereço.duckdns:port”, pois eu estava com o ip do Raspberry.
E adicionei o “tts:” no meu caso “- platform: google”. Aceder ao HA pelo duckdns e agora sim, Habemus TTS e controlo do ghm :grin:


(Marco Pinheiro) #13

E tens ligação com HTTPS?


(karma) #14

Sim. Tens é adicionar o duckdns no base_url. Só assim me permitiu o tts funcionar


(Marco Pinheiro) #15

Ah ok ok, já percebi. Logo à noite já vejo se ela fala (já afinei aqui a config. mas estou fora). Obrigado Karma.


(Marco Pinheiro) #16

Humm não funciona … Alguma pista?

`About Home Assistant 0.82.1

Error executing service <ServiceCall tts.google_say (c:b344910acd264633ae6e895f7d1cf95c): message=Hi Marco!, entity_id=[‘media_player.living_room_speaker’]>
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/tts/init.py”, line 137, in async_say_handle
options=options
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/tts/init.py”, line 306, in async_get_url
engine, key, message, use_cache, language, options)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/tts/init.py”, line 318, in async_get_tts_audio
message, language, options)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/tts/google.py”, line 83, in async_get_tts_audio
token.calculate_token, part)
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(self.args, **self.kwargs)
File “/usr/local/lib/python3.6/site-packages/gtts_token/gtts_token.py”, line 28, in calculate_token
seed = self._get_token_key()
File “/usr/local/lib/python3.6/site-packages/gtts_token/gtts_token.py”, line 57, in _get_token_key
tkk_expr = re.search(".
?(TKK=.?;)W.?", line).group(1)
AttributeError: ‘NoneType’ object has no attribute ‘group’`


(karma) #17

Como tens o media_player configurado no HA? Metes-te como o @j_assuncao disse?


(Jorge Assunção) #18

A API está correcta na configuração?

Que código estás a usar para configurar o TTS?


(Marco Pinheiro) #19

Pois, algo me está a escapar, já fiquei confuso.

Tenho apenas assim o tts

tts:

  • platform: google

Mas agora que estive a ver, acho que não tenho, no código, configurado o google home mini declaradamente, estou a referir-me a ele no script apanhando o nome dele que surge nos devices. Só tenho isto no config:

media_player:

  • platform: cast

Depois no script tenho uma coisa simples para já:

say_hello:
  sequence:
    - service: tts.google_say
      entity_id: media_player.living_room_speaker
      data:
        message: "Hi Marco!"

(karma) #20

Faz antes assim:

cast:
  media_player:
    - host: 192.168.1.19 -> ip do ghm

Mas vamos por partes.
O ghm quando está a tocar musica, consegues ver o album em questão no HA?