Upgrade para 0.68.1


(Ricardo Neiva) #1

Boas,
Estou com um problema ao actualizar para o 0.68.1.
Tenho a versão 0.66.1 do HomeAssistant instalado num UbuntuServer.
Estou a tentar atualizar como sempre, com os seguintes comandos:

sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 install --upgrade homeassistant 

O problema é que dá-me um erro e não actualiza:

https://pastebin.com/C5KVACtk

Alguem com uma luz sobre isto?


(Jorge Assunção) #2

Qual é a versão do Python?


(Diogo Gomes) #3

(homeassistant) homeassistant@HomeAssistant:/root$ pip3 install --upgrade homeassistant

só com esta linha aposto que todo o problema é de permissões…

$ sudo chown homeassistant /srv -R


(Ricardo Neiva) #4

@j_assuncao:

(homeassistant) homeassistant@HomeAssistant:/root$ pip3 --version
pip 10.0.1 from /srv/homeassistant/lib/python3.6/site-packages/pip (python 3.6)

@dgomes, depois de executar o chown recebo isto ao tentar fazer update:

https://pastebin.com/fy3FpzcS

Pelo que percebo tem haver com a versão do cryptography ser demasiado elevada para o pyxiaomigateway.


(Diogo Gomes) #5

Esse erro é estranho pq o cryptography não é uma dependência do HA…

corre apenas:

$ pip3 install pyxiaomigateway

e depois tenta de novo


(Ricardo Neiva) #6

Funcionou!

Obrigado mais uma vez @dgomes!