Weather Platform - IPMA


(Ricardo Reis) #81

eu coloquei porque estava a dar o mesmo erro sem as coordenadas. Para ter a certeza que não seria por causa disso, forcei a informação


(Nuno Neves) #82

Não sei se as indentações que colocaste acima estão iguais à configuração que tens, mas os espaços estão em número ímpar relativamente à borda esquerda, quando deveriam ser em número par…

Tenta com as seguintes coordenadas:
40.953815
-8.655993

As que tens parecem ser no mar…


(Ricardo Reis) #83

tenho os espaços com número par. Tem 1 espaço a mais neste código, falha ao colar.
Editei o post anterior, aparece-me aquele erro, o script do ipma não detecta as coordenadas GPS


(Nuno Neves) #84

Tenta com as seguintes coordenadas:
40.953815
-8.655993

As que tens parecem ser no mar…


(Ricardo Reis) #85

Já experimentei, mesmo assim continua igual. Continua o mesmo erro


(Diogo Gomes) #86

apaga o ficheiro ipma do custom_components, o mesmo não é necessario.

o modulo já foi integrado na versão oficial e pode ser esse problema


(Alexandre Oliveira) #87

Boa tarde pessoal… Já tenho a funcionar o ipma… Mas não colocei coordenadas… E funciona bem pois tenho as coordenadas do ficheiro conf…Agora eu gostaria de ter mais locais indroduzidos. Como posso fazer isso?, obrigado


(Diogo Gomes) #88

Tens q duplicar o componente e colocar coordenadas nos novos


(Jorge Assunção) #89

Duplica-se no configurations.yaml?


(Alexandre Oliveira) #90

Boa tarde pessoal, esta é a minha conf…só que as temperaduras e os outros valores nao batem certo…ou é coincidência, estranho… tenho algo mal?
obrigado

 weather:
      - platform: ipma
        name: Guarda
        latitude: 40.52855833
        longitude: -7.27867500

      - platform: ipma
        name: Viseu
        latitude: 40.66273889
        longitude: -7.90396944


(Rodolfo) #91

Olá.
O @dgomes quando tiver oportunidade responde a essa questão.


(Alexandre Oliveira) #92

Agora adicionei beja só para o teste:


obrigado pela atenção @RodolfoVieira @dgomes


(Diogo Gomes) #93

OK… IPMA mudou a API :frowning: estou ja a trabalhar uma nova versao!


(Diogo Gomes) #94

Se alguem poder testar:

Editar homeassistant/components/weather/ipma.py

Na linha REQUIREMENTS = ['pyipma==1.1.3']

Substituir por REQUIREMENTS = ['pyipma==1.1.4']

Reportar erros :slight_smile:


(Alexandre Oliveira) #95

bom dia,
Já alterei, sem erros…mas continua tudo igual.


(Diogo Gomes) #96

Não pode continuar igual de todo :slight_smile:

Eu testei com a tua configuração e tudo :smiley:, teem que ser todos diferentes os cartões …


(Alexandre Oliveira) #97

pois, não sei o que está errado…já aconteceu a mais alguem este problema? eu so configurei isto
ipma.yaml

weather:
  - platform: ipma
    name: Aveiro
    latitude: 40.63540000
    longitude: -8.65961111

  - platform: ipma
    name: Guarda
    latitude: 40.52855833
    longitude: -7.27867500

  - platform: ipma
    name: Viseu
    latitude: 40.66273889
    longitude: -7.90396944

nao alterei mais file nenhum.


(Diogo Gomes) #98

Como é q alteraste o ficheiro ipma.py ?

Tens hassio ?


(Alexandre Oliveira) #99

Com o editor de texto nano.

nano ipma.py

REQUIREMENTS = ['pyipma==1.1.4']


(Nuno Couto) #100

Boa tarde…

Tenho Hassio … como faço para alterar o ficheiro?

Obrigado,